Printing multi docs not working

but when i use node -v the output is v18.20.1

Then you have node18 somewhere but not being used by supervisor.

Do which node and set that in supervisor config.

thank you for your help but can you explain for me the steps im not very familiar with these things

  • which node will give you path to node18. Copy it and store it somewhere.
  • now edit supervisor config file. Find /usr/bin/node and replace ot with node18 path.
  • save edits
  • sudo supervisorctl reread
  • sudo supervisorctl restart all:

Create copy of supervisor file in case you mess it up and need to restore.

bench setup supervisor can work too. But I’m not sure why it didn’t pick right version in first place, so not sure if rerunning it will find right node version now.

i have done every thing as per you instruction but when i request for “sudo supervisorctl status” i got this status

frappe-bench-redis:frappe-bench-redis-cache RUNNING pid 3369, uptime 0:01:40
frappe-bench-redis:frappe-bench-redis-queue RUNNING pid 3370, uptime 0:01:40
frappe-bench-web:frappe-bench-frappe-web RUNNING pid 3371, uptime 0:01:40
frappe-bench-web:frappe-bench-node-socketio BACKOFF Exited too quickly (process log may have details)
frappe-bench-workers:frappe-bench-frappe-long-worker-0 RUNNING pid 3375, uptime 0:01:40
frappe-bench-workers:frappe-bench-frappe-schedule RUNNING pid 3373, uptime 0:01:40
frappe-bench-workers:frappe-bench-frappe-short-worker-0 RUNNING pid 3374, uptime 0:01:40

by the way i have the same issue even when im in developer mode

site_config.json , I tried adding host_name, and it solved

I am facing the same issue.

My ERPnext Version is:
ERPNext: v15.27.7 (version-15)
Frappe Framework: v15.30.0 (version-15)
Gameplan: v0.0.1 (main)
Frappe HR: v15.22.2 (version-15)
India Compliance: v15.8.1 (version-15)

When I click on Print, No action is performed and there is no error in the console.

@shuai can you share, how you added host_name ?

run bench command

bench add-to-hosts