Problem sending email by form

Hi Guys,

i done the email setting and i able to send the email to user when reset password and creation of new account.
But face the problem to send the email by using the form as stated below:

It totally didn’t have any errors messages shown.
Can someone helps on this?


check the email queue for sent mail if the mail are not sent from the Email Queue might be your scheduler is not running to enable the scheduler run the bench --site your_sitename enable-scheduler command


1 Like


the site have been enabled but the email still not been send out.
Is there any way to check the pending email queue?


Just search the Email Queue in Awesome Bar

1 Like

thanks @makarand_b for help.

I manage to find the list.
After i click the ‘send now’ for the Not send email and it is working.
Is it possible to send out the email within 5 minutes or instantly after the email start been queue instead of i need to manually click the ‘send now’ button?


Email should be sent automatically from Email Queue by scheduler after every 5-6 mins interval.

Please check the Error Log (search the Error Log in the awesome bar) or you can also check the Background Jobs page in case if there is any error while sending an email. Also, check System Settings Background Worker section and enable scheduler if it is disabled.


‘enable Scheduled Jobs’ have been enabled since erpnext been installed

Error log is only show the previous error log which was solved by setting default email

Background Jobs page didn’t have any errors as i able to click ‘send now’ for all the ‘not send’ email and their status changed to sent.

Same Problem here.

I find all my outgoing mails in the queue but they are not sent automatically.
If I click in the mail to “Send now” I git the mail sent.

I have in worker.error.log the following message (I replaced my email and IP):

17:15:53 default: frappe.utils.background_jobs.execute_job(async=True, event=u'sendmail', job_name=u'<function sendmail at 0x7f9e5483bb90>', kwargs={'lang': u'en-US', 'attachments': [], 'recipients': [u''], 'cc': [], 'print_format': u'', 'session': {u'data': {u'session_expiry': u'06:00:00', u'session_country': 'DE', 'csrf_token': 'da4ebb5b00e65974a76571c121a72e310e094c14f094a841056625f7', u'last_updated': '2017-04-29 17:15:47.349776', u'lang': u'en-US', u'user_type': u'System User', 'user': u'', u'full_name': u'Guest', u'device': u'desktop', 'session_ip': u''}, u'user': u'', u'sid': u'60ff8e376e290679f65205fd42fd090e7b2cfacca19553b7bdf5a474'}, 'communication_name': 'efadd356c2', 'print_html': u''}, method=<function sendmail at 0x7f9e5483bb90>, site=u'mysitename', user=u'') (8d8bfc20-1bc8-4ebb-ba6a-75b8ebb5579b) 17:15:53 default: Job OK (8d8bfc20-1bc8-4ebb-ba6a-75b8ebb5579b) 17:15:53 Result is kept for 500 seconds

Update: Very Strange: I got now this Email delivered at 18:05 (50 mins later).

Are there any settings for configuring the scheduler?

1 Like

Hi, does anyone find solution for this.

You mean like this?

frappe@erpnext:~/frappe-bench$ bench set-config scheduler_interval 901

that change you will find here

frappe@erpnext:~/frappe-bench$ find . -name ‘site_*.json’ | xargs grep ‘scheduler_interval’
./sites/erpnext.vm/site_config.json: “scheduler_interval”: “901”

To effect the change you may need to restart the scheduler?

Run ‘bench --help’ to learn more…

You may have to enable crontab and set it up as per your requirement. @paulator