Problem with bench update!


I am having a problem with running bench update on my production server.
Just to clarify absolutely nothing has been changed in the core files or anything else to be honest. The exact same setup since every other time we run bench update.

Now I am running bench update and at the end the ERPNext site is just showing that an update in currentlyin progress.
On the ssh part I get at the end of the bench update command

_mysql_exceptions.OperationalError: (2006, ‘Mysql Server has gone away’)
Restarted Mysql with sudo and tried the bench update again. The outcome is always the same and the site is not accessible now!

What can I do? I saw this article When updating bench - CommandFailedError: git pull upstream develop - #5 but I dont know those hard resets will lose my data or not?


Have you checked if your server is not out of memory ?

It happens that mysql service stops on bench update/or site creation on small servers with not enough memory or swap configured.

I am using the image for Virtual Box.
I have set 8 gigs of RAM and 40GB of HDD so I suppose it should be just fine on that part.

Hi @xdelios,
Please check this:


Hi George;

The Hard reset will only change the python .py and javascript .js
programs under frappe folder but will not change your data.
So if you have made any changes in the programs under frappe folder or
erpnext folder you will lose those changes, but not the database, the
database will not change.
But I think your problem is in Mysql (MariaDB) not in frappe.

Best regards.

Hisham M. Farid


Ok so I tried the solutions that I could find. Tried the ones in the article posted above.
It did not work.

After all I updated Node Js version and that seemed to do the trick. I dont understand how is itu possible though that his was the problem in the first place. Everything is working fine now.