Problem with sorting filters in list view


I have a problem when I try to sort a table. The sorting filter is obviously never applied.
Here are the steps to reproduce the problem (I’m a new user and I can only upload one picture…) :

  1. Go to the DocType List view and select the DocType you want to modify.
  2. Go to the “View Settings” section and modify the “Default Sort Field” and the “Default Sort Order” values.
    For example : Default Sort Field = identification, Default Sort Order = ASC
  3. Save the changes and go to your view list.
  4. The filter is always locked on “Last Modified On” and the value is never updated.

As you can see, the sorting filter is always locked on “Last Modified On”, but the sorting filter should be “Identification”. I also tried with a customization form, but it still doesn’t work.

I’m currently working on version 14 beta of Frappe but I have the same issue on previous versions.

Am I doing it wrong or is it a bug that needs to be fixed?

Thanks for your answers :slight_smile:


I tried to modify the Stock Entry doctype and the message :

DocTypes can not be modified, please use [Customize Form]

So I tried to customize the form and change the sort field and order in the List Settings. The field changed but the order did not. This is v14 beta as well.

@smino, exactly the same issue.

I guess we’ve just found a new bug.

Not a new bug, it’s been around for years. That’s how quick bugs get fixed.

Complicating the issue is that each user’s list view settings preferences are saved in the cache (including filters), so once you have loaded a list view once, those are your preferences. They persist across a cache-clear but if you restart redis they are reset. But yes, the initial default set in the doctype is not used.