Problemas a la hora de actualizar

El error sucede cuando intento actualizar (bench update)

Backing up sites…
Patching sites…
Migrating protelca
Executing erpnext.patches.v9_2.rename_translated_domains_in_en in protelca (dbprotelca)
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe.dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 217, in migrate
migrate(context.verbose, rebuild_website=rebuild_website)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 31, in migrate
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 29, in run_all
if not run_single(patchmodule = patch):
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 63, in run_single
return execute_patch(patchmodule, method, methodargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 83, in execute_patch
frappe.get_attr(patchmodule.split()[0] + “.execute”)()
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/patches/v9_2/”, line 16, in execute
frappe.rename_doc(“Domain”, translated_domain, domain, ignore_permissions=True, merge=True)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 696, in rename_doc
return rename_doc(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 39, in rename_doc
new = validate_rename(doctype, new, meta, merge, force, ignore_permissions)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 117, in validate_rename
(“{0} {1} does not exist, select a new target to merge”).format(doctype, new), raise_exception=1)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 309, in msgprint
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 284, in _raise_exception
raise ValidationError(encode(msg))
frappe.exceptions.ValidationError: Domain Manufacturing no existe, seleccione un nuevo objetivo para fusionar

1 Like

bench migrate and then update it?

I’ve already tried it without getting results … It seems that the argument --upgrade was not added in version 9

i have same problem after update erpnext from 9.2.0 to 9.2.21

Me informan que quitaron esta opcion y que simplemente aparece en update te pregunta si deseas migrar si / no. siempre y cuando exista una actualizacion

today @saurabh6790 fixed this patch :wink:

The Issue still is present…I also try to update a "fresh instal"l using the official VM and still the same results

Please share a traceback!

Hi I get the same error albertfns inform. What I did is:
Download the OVA
Setup a company witIh service Domain
Afer succesfull install I did a bench update

This is the error I get

Sorry for the screen shot I’m newbie at ERP Next

I just realize if the system language is set to english you can update without errors, :slight_smile: problems arise with translations

I updated system language from mysql command line but it not solve this problem. Any idea?

I change the system language and the administrator language on erp next user interface not directly on DB

I change system language by mariadb because ERPNext was crashed.

I was not able to recover from crash…As I am not a expert ERPNext user I did a new installation. After a crash experience I have 2 VM… 1 for production and other for testing purposes. I try nothing on my production VM.