Product items still appear on homepage although already disabled

Hi everyone,

During initial setup (wizard), i created two product items, and default check is display on website.
Now, i don’t want to display them on homepage, so i disabled option “Show in Website” for each item, however these items are still appears on website homepage.

Any idea how could i fix it?
Thank you.

Go to Website → Homepage. Remove products from the PRODUCT table (Products to be shown on website homepage)


thanks @KanchanChauhan for your tip.
i have followed, but these removed products are now showing as “Product 0”, “Product 1”, “Product 2”

I attached the screenshot below.

That is the default behavior, there has to be atleast 3 products. You can change it by deleting these line from


thanks @KanchanChauhan
is there no way to manage it via Website setting or menu other than adjusting the code?

No, not yet. But you can raise the feature request for the same on github.

1 Like

OK. I see.
Thanks @KanchanChauhan