Production Plan - Kanban Error: DocType undefined not found / The resource you are looking for is not available

Hi everyone, as per the title above, I faced an error when I am attempting to create a Kanban for Production Plan. The error message reads:

DocType undefined not found
The resource you are looking for is not available

ERPNext: v12.2.0 (version-12)
Frappe Framework: v12.0.20 (version-12)

@Raymond_Liew, This error could be, your doctype with the given name is not available. Check if doctype’s name is correct or available. If not can you please provide more information about your problem? Thank you. :slight_smile:

Hi @pabon_cse_12

I am not quite sure of what you mean here. Anyway, below is the list of existing Production Plan I have.

In creating a Kanban, I have tried all 3 available options in the "Column Based On’ field: Naming Series, Get Items From and Status. All 3 of them show the same error.

Let me see this, please. I will be back soon.

1 Like

@Raymond_Liew, Kanban Board can be created for those fields which are defined as “select” field types. Are these 3 fields’ types are set to select?

Yes, they are still ‘select’ type of fields as I didn’t amend anything.

P.S. I just updated to
ERPNext: v12.2.2
Frappe Framework: v12.0.20
still having the same issue

I am also getting same error. #Help .#Thanks.

1 Like

Same issue

This problem still persist in v12.3.1 (version-12)

Hi thanks for reporting this @Raymond_Liew

Please include a text copy of the complete traceback - the stack trace specifies exactly what the code is doing. To retrieve that requires a self-hosted environment, where you will need access to the server logs.

Unfortunately, I could not find the traceback for the error. I have tried ‘triggering’ the error but still couldn’t find the traceback.

@SanRam @Ernesto, how bout you guys? Are you able to retrieve the traceback for the error?

Yes the steps to create the error and the full traceback (aka the stacktrace) are key to discover a recurring problem, the last line of the error gives clues but entrails matter the most…

I am getting the same issue still in (ERPNext: v13.12.1 (version-13),Frappe Framework: v13.12.1 (version-13)) when working with kanban board. Kanban Board [“Lead”] not found. The resource you are looking for is not available. Renaming Kanban board name doesn’t work.

This happens when DocType does not have title field set. The error could be better, or title should be a requirement for creating a Kanban board for a given DocType.