Purchase Invoice Submit Displays "Request Timed Out" Error Message

Hi All,

I had read previous cries for help on this “Request Timed Out” issue before I am posting this. Now I am posting it still because the previous posts (and suggested solutions) did not help me. May be, I do not know what to do with suggested solutions in those cases.

We had no issues at all submitting Purchase Invoices until this morning when it started. Now, when we try to submit a Purchase Invoice, it runs forever and returns the message “Request Timed Out”.

In one of the other posts I read, someone had suggested that perhaps the problem had to do with large volume of transactions or something of that nature. Well, in this case, the client has just gone live with ERPNext and they had successfully submitted six (6) purchase invoices previously. But now they cannot.

Please help.

I had a vaguely similar issue with productions a long time ago (Worker timeout (Stock Entry/transfer on Production Orders) - #10 by trentmu).
I found that if I just left the screen with the message about the timeout (ie. don’t click Close) for a while (sometimes as much as 3mins) it finished the submit in the background. I never got as far as solving it, but maybe you will get some ideas from the logs etc that I posted there, and can sort out that one too :grin:

I suspect it is just a database problem, as I had not optimised my DB at all. I will get back to it in the next few weeks. Perhaps your system will exibit behaviours that allow a more accurate ID of the problem.

Thanks @trentmu

Update info:

We noticed this morning that, using the Data Import Tool, we can actually get the purchase invoices submitted.

In the Data Import Tool we downloaded the invoices with data to Excel, deleted invoices already submitted, and imported the purchase invoices that we couldn’t submit manually (i.e., invoices with the “Draft” status). And…after about a minute or so, the “In Progress” messaged changed to “Successful”. it worked.

Problem though is we still have to explain to our client why they cannot submit purchase invoices manually as they used to do before the error occurred yesterday.

Help! Help! Please!


Have you tried all the threads about optimising the DB buffers, settings etc, and also increased the number of worker threads for gunicorn?

@trentmu. Our guys are working it, though not resolved yet.

Thanks for your assistance. Much appreciated.

1 Like