Purchase Receipt


I made purcahse receipt againts PO. When submiited, it didn;t post accounting entries.
“No Accounting entries for warehouses: Warehouse A…”

I’ve looked through the settings but didn;t find the reasons why it didn’t post journal entries…

Any ideas? Pls help…



Error message indicates that accounting ledger doesn’t exist for the Warehouse. Please create new Warehouse, and then use it in the Purchase Receipt.

Made new warehouse and receipt worked well, but now the warehouse showed same error again (no accounting entries…) after I renamed it. What to do? I think create new warehouse again is not a solution…

Any ideas?


Can you raise a GitHub Issue for this

@Jonathan_Fanny_Lie Have you migrated v4 to v5? In that case, just update again, I have pushed a fix.

Otherwise open account record for the concerned warehouse and check account_type and warehouse set correctly.

Thanks @nabinhait . I’m using v5
It seemed after renamed the warehouse, the account record didn’t change to refer to that warehouse. Also, I could not set the warehouse for the account…
So I created new warehouse and then merged it with existing…


I’m using v5.0.11 now and this issue still persists…after renaming warehouse, all stock transactions for that warehouse shows : No Accounting Entries.

I checked warehouse account and it’s set correctly. This error happens after renaming warehouse master.

I think there should be validation that prevents stock ledger entry if accounting entriy fails and vice-versa. Otherwise there’ll be different balance between stock ledger and warehouse account.


Any feedback on this? At least there should be validation to prevent stock ledger posting if accounting entry fails.

So what’s the correct ways to rename a warehouse?