Quotation document cannot be seen in browser


When a Quotation is received by e-mail, and clicked the link to see it in browser, this URL is loaded:


That way, a resource not found error is shown.

Any help?

Of course, “erp.server.com” host is just an example to hide real server.



The Quotation might be deleted by someone.


That is obviously not the case.

I am the only user in the system and I have installed ERPNext in my own CentOS system.

Having a validated quotation in ERPNext system, I send it by e-mail. When received the e-mail, the PDF file is attached.

The body of the e-mail has a link to view the quotation in browser. I click the link and a resource not found error is shown.

The link in browser is: https://erp.server.com/Quotation/QUO19/0058?format=Standard&key=29bbdd9c0cfcab906c699f12e8f8169c43c0d3d76c00ae8cbb2c7d33

By comparing this to the link when I see the quotation in ERPNext system, this is it:


If I add “desk#Form” part in the link that comes in the e-mail, a not authorized error is shown.

That is why I reported this to be a bug. The problem is not that obvious such as “the quotation might be deleted by someone”.

I need to fix this before I send the quotation to my customer.


Does your server host pages from other than the default port 80? when nginx port is changed the url link in the email welcome to register is not updated · Issue #17044 · frappe/erpnext · GitHub

No… in fact… I have made a test sending recovery password e-mail and it worked. When I click the link in the e-mail, ERPNext page was loaded allowing me to change password.

The problem is only when trying to see a document.


What does this mean?

Hello, if this cannot be solved, is there a way to avoid the E-mail to have a link to see quotation in browser?

That link is added automatically after the text I entered.


Forget it… it is in printing settings. I could disable it.

However, I think this should be solved by developers.