Receiving Internal Server Error on Chrome after updating to V12

I am using ERPNext on Oracle Virtualbox on Windows 7. After upgrading to V12 I am receiving Internal Server Error.
The upgrade went fine but when I Bench update --patch it gives me an error
“Uknown column 'total_taxes_and_charges in 'where clause”

and now I cannot access erpnext anymore. I have 4 months data with no backup.

Can I reinstall v11 ? I am very new to Ubuntu

Please help

you can try in the console: bench backup . to see if the site can be backed up. Then see what bench migrate returns

Thank you for your reply.
I did Bench backup it returned nothing.

How can I know if my site is backed up where would the location be.

I did Bench migrate after that and got the same as bench update --patch. The result is just before the Bench backup in the image above

waiting for your help desperately

Check the private files folder under sites for backups.

From frappe bench: cd sites/sitename/private/backups

thank you @kennethsequeira. I tried that but it said no such directory. Please see image below

erpcom is a site of mine. In Your case, it would be site1.local. Go inside sites > site1.local and check.

thanks. It worked so I guess it is backing up

but how would I know that this back up is proper

then what now. How can I get my erpnext working again. Can I install another instance and restore the backup to make sure it is working?

I would suggest copying the files in the backups folder to another location. Your instance is probably salvageable, with a bit of work. I would start by upgrading the Ubuntu to 18 if it isnt already. I would also upgrade yarn and nodejs to latest. Then try , from the ~/frappe-bench folder: bench migrate-env python3.6 then bench setup requirements. If that all goes smoothly try bench migrate again.

Thank you @smino for trying to help me.

I did the following:

I copied the backups folder to the root directory

I tried
sudo apt update
sudo apt upgrade
sudo reboot (waited for 5 minutes but nothing happened) so I powered off the VM and started it again.
When I typed sudo do-release-upgrade I got the following

and still on ubuntu 16.04
so should I proceed or wait for your help on upgrading ubuntu

sudo apt-get install --reinstall python3-apt

then try the release udate again, you may have to remove and reinstall python3 and python3-dev

Thank you @smino for keeping up with me I really appreciate it

Below is what I got

I don’t know how to remove and reinstall python3 and paython3-dev

sudo apt remove --purge python3
sudo apt remove python3-dev
sudo apt install python3 python3-dev python-apt-dev

I am not sure what is going on:

I did the python removal and reinstall

now I am getting: no command found for the do-release

and when I restart the vm I get

Can’t say whays going on with it, it appears that it was not shut down gracefully and damage may have occurred. Can you allocate a bit more disk space to the VM and try booting again. If your database backup is intact it might be easier to set up a fresh instance and restore it once everything is up to date.

I think this is what I am gong to do.
Can I install a fresh instance while keeping this whole thing so I will have 2 VMs this way I make sure my data transfer correctly for discarding this one. Also how do I copy my backup to the new instance

If the backup is downloaded to a local drive it can be uploaded to the new instance , if it was not transferred out of the VM the VM will have to be repaired and booted in order to retrieve it.

How do I transfer it out of the VM and into windows and how do I repair the VM

I installed another instance. It is working fine. But now I need to transfer the site from my old instance to the new one how do I do that

Try allocating more disk space to the first VM and booting it. If it does not boot someone more familiar with Virtualbox will have to say how to repair the filesystem if it is corrupted

Hi @smino sorry I might have given you wrong information. The VM is booting. It is giving me the previous msg but it does boot and I have the backup. I also installed a second instance on the vm which is working fine.

Now I need to transfer the backed up site from the old instance to the new one. How can I do that