Recreating the softlink to /etc/nginx/conf.d/frappe.conf [SOLVED]

I was trying to re-setup the bench production version after removing the previous one. I was getting this error-

Installing for Ubuntu vivid amd64
In case you encounter an error, you can post on

Adding ubuntu mariadb repo
Installing packages for Ubuntu. This might take time...
Installing wkhtmltopdf
Installing wkhtmltox package for trusty (Ubuntu 14.4) even if you are using vivid.
Adding frappe user
Installing frappe-bench
Setting up first site
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 9, in <module>
load_entry_point('bench==0.92', 'console_scripts', 'bench')()
  File "/home/reza/bench-repo/bench/", line 60, in cli
  File "/usr/local/lib/python2.7/dist-packages/click/", line 700, in __call__
return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 680, in main
rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/", line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/", line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 508, in invoke
return callback(*args, **kwargs)
  File "/home/reza/bench-repo/bench/", line 459, in setup_production
  File "/home/reza/bench-repo/bench/", line 64, in setup_production
  os.symlink(os.path.abspath(os.path.join(bench, 'config', 'supervisor.conf')), os.path.join(get_supervisor_confdir(), supervisor_conf_filename))
OSError: [Errno 17] File exists

Than, i have removed the /etc/nginx/conf.d/frappe.conf via this command-

sudo rm /etc/nginx/conf.d/frappe.conf

After that, i have tried to reinstall it again and same error occurs. One person suggests me to check the softlink to frappe.conf and it seems to be broken.

How can i recreate the softlink?

Solved. The process of recreation of softlink is given in the production section of github repo.

1 Like

This topic was automatically closed 29 hours after the last reply. New replies are no longer allowed.