Redis cache server not running. Please contact Administrator / Tech support

Hi Guys,

After upgrading from 4 to 5
I login and then get this error

Redis cache server not running. Please contact Administrator / Tech support

And confirm redis is running on 6379

Any Idea’s

Thank you

1 Like


bench retry-upgrade

It should regenerate config and print required steps

after run bench retry -upgrade
it shows no this coomand, why?
at same time, I can’t use bench switch-to-develop.

Try bench update first. This command was recently added.

Yes Okay I will.

Thanks Pdvyas / Jschen

Hi again sorry sorry, getting this error now. but isn’t with, bench retry-upgrade

Redis keeps saing:
22:34:18 redis_cache.1 | [9041] 06 Apr 22:34:18.841 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.

Anything we can do here?

AND Also

When I do a fresh install

So login on frappe, go to installer, then install ERPNext (RED),
And then Error’s install…


22:34:34 web.1 | Installing erpnext…
Updating erpnext : [===== ] - - [06/Apr/2015 22:35:00] “POST / HTTP/1.1” 200 -
Updating erpnext : [============== ]
22:35:28 web.1 | 2015-04-06 22:35:28,687 Request Error
22:35:28 web.1 | site: site1.local
22:35:28 web.1 | form: {‘cmd’: u’’,
22:35:28 web.1 | ‘name’: u’erpnext’}

22:35:28 web.1 | Traceback (innermost last):
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/”, line 51, in application
22:35:28 web.1 | response = frappe.handler.handle()
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/”, line 62, in handle
22:35:28 web.1 | execute_cmd(cmd)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/”, line 85, in execute_cmd
22:35:28 web.1 | ret =, **frappe.form_dict)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/”, line 718, in call
22:35:28 web.1 | return fn(*args, **newargs)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/desk/page/applications/”, line 36, in install_app
22:35:28 web.1 | frappe.installer.install_app(name)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/”, line 122, in install_app
22:35:28 web.1 | sync_for(name, force=True, sync_everything=True, verbose=verbose)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/model/”, line 43, in sync_for
22:35:28 web.1 | import_file_by_path(doc_path, force=force)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 54, in import_file_by_path
22:35:28 web.1 | import_doc(doc, force=force, data_import=data_import)
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 120, in import_doc
22:35:28 web.1 | doc.insert()
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/model/”, line 190, in insert
22:35:28 web.1 | d.db_insert()
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/model/”, line 239, in db_insert
22:35:28 web.1 | d = self.get_valid_dict()
22:35:28 web.1 | File “/opt/frappe/frappe-bench/apps/frappe/frappe/model/”, line 177, in get_valid_dict
22:35:28 web.1 | if d[fieldname]==“” and self.meta.get_field(fieldname).fieldtype in (“Datetime”, “Date”):
22:35:28 web.1 | AttributeError: ‘NoneType’ object has no attribute ‘fieldtype’

This needs fixing…
So I hope this helps others as well.

Best Regards

Fixed. Please update.


I have just updated and tried bench retry-upgrade, and I am having same error as Vitridex:

Redis cache server not running. Please contact Administrator / Tech support

Everything seems to be working right, it is just a notice that you close and everything keepsworking okay.

Thanks and regards,

I have the same thing. I also updated today and the message is not going. I
think it has effect on the speed of the system.

I think my reply didn’t go through


bench update
bench retry-upgrade
sudo supervisorctl reload
sudo service nginx reload

on my host (Erpnext v5) bench retry-upgrade doesn’t work

bench retry-upgrade
Usage: bench [OPTIONS] COMMAND [ARGS]...

Error: No such command "retry-upgrade".

I have a similar problem and when logging into ERPNEXT v5 I get the error message “Redis cache server not running…”. We did not do an upgrade though, we went straight to v5 under the develop branch and this error appeared only after a bench update yesterday.

Yes, we separated redis for celery and cache two weeks back


bench update
bench retry-upgrade

@dtran, maybe your bench is old. Try the above commands

1 Like

Wonderful! this worked for me… Thank you.

I try bench update many time already, but I don’t know why bench is still old version and dont have bench retry-upgrade

I run Erpnext v5 from the VM Appliance (upgrade from erpnext 4)

How to update Bench itself?

Hi pdvyas,

Many thanks. This worked for me!

Thanks and regards,

Update bench manually,

cd ~/bench-repo
git pull

and try again.

Thanks pdvyas, and to all… :smile:

The problem is Fixed now.

Case Closed.


Hi pdvyas,

git pull

on bench-repo work for me

bench update
bench retry-upgrade

also work
but when I open the Desk, it still warning Redis cache server not running!
Redis is listen on port 6379 I have no idea ?_? Is there a way to reset redis to default Erpnext configuration.

Then, there must be an error,

cd ~/frappe-bench
redis-server config/redis.conf

Does this work?