[Release Note] ERPNext Version 12

I tried your method but just in erpnext dir and it failed when building frappe assets. I then repeated it but this time i ran git config remote.upstream.fetch “+refs/heads/ :refs/remotes/upstream/ ” also on the frappe dir and everything worked fine but i got we will be back soon when trying to log in.

I have checked supervisor status using supervisorctl status and everything is running. I also restarted but no luck.


I just checked my web.error.log file and found this error:

Traceback (most recent call last):
  File "/home/octo5/frappe-bench/env/bin/gunicorn", line 10, in <module>
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/wsgiapp.py", line 61, in run
    WSGIApplication("%(prog)s [OPTIONS] [APP_MODULE]").run()
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/base.py", line 223, in run
    super(Application, self).run()
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/base.py", line 72, in run
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/arbiter.py", line 60, in __init__
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/arbiter.py", line 120, in setup
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/base.py", line 67, in wsgi
    self.callable = self.load()
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/wsgiapp.py", line 52, in load
    return self.load_wsgiapp()
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/wsgiapp.py", line 41, in load_wsgia$
    return util.import_app(self.app_uri)
  File "/home/octo5/frappe-bench/env/lib/python3.6/site-packages/gunicorn/util.py", line 350, in import_app
  File "/home/octo5/frappe-bench/apps/frappe/frappe/app.py", line 27, in <module>
    import frappe.recorder
  File "/home/octo5/frappe-bench/apps/frappe/frappe/recorder.py", line 14, in <module>
    import sqlparse
ModuleNotFoundError: No module named 'sqlparse'

Any idea if this could be the cause?

Actually, I didn’t miss the *s in the command. The forum doesn’t show the *s. So replacing the * with (star) for your comprehension. Here’s the command:

git config remote.upstream.fetch “+refs/heads/(star):refs/remotes/upstream/(star)” from erpnext and then

bench switch-to-branch version-12 --upgrade
bench update --patch

Hope that helps.



okay. but to reconfirm, am i to run it in only the erpnext directory?

UPDATE: Upgrade completed successfully but only frappe upgraded to v12. erpnext is still on v11

can anyone point out what would be the latest moment when to run the …

switch-to-branch [version]

… command when your instance is on the master branch currently?

not 100% sure if that is still relevant but from switching branches from staging to master las time , but as far as I remember …

switch-to-branch [branch] --upgrade

… would be the ideal command of choice.

Okay, sorry if I am getting too detailed. :slight_smile:

git config remote.upstream.fetch “+refs/heads/(star):refs/remotes/upstream/(star)” from erpnext and then

from frappe-bench directory

bench switch-to-branch version-12 --upgrade
bench update --patch

Hope that helps.




I figured i’d need to do that so i already did. But when i try to migrate i get this error:

frappe.exceptions.DoesNotExistError: DocType Item Manufacturer not found

I essentially gave up, setup a new v12 instance and restored backup and everything is fine. i have tried direct upgrade all day and it doesn’t work


Just scroll up a little bit:

Hope it helps.

1 Like

Please clarify if:
production systems which were on master need to change either to version-11 or version-12 and both still are valid versions.

very confusing from the start. Here below:

"Repository Changes
The branches on the ERPNext & Frappe repositories are being renamed as follows:

Old Name New Name
develop version-12
master version-11
hotfix version-11-hotfix
Note: The master branch has been deprecated as of today i.e. 22 July, 2019.

Following are the new branches created:

develop: Version 13
version-12-hotfix: Staging area for version 12 fixes
Please note, all your open PRs have to be rebased to the new branch."

Please also note that there are systems on production.

I think i’m more or less there - but I have been stuck all day yesterday and now today on the rollup build taking forever or not happening at all…

/home/frappe/frappe-bench$ sudo bench update --build
Backing up sites...
INFO:bench.utils:bench build
yarn run v1.17.3
$ FRAPPE_ENV=production node rollup/build.js
Production mode
✔ Built js/moment-bundle.min.js
✔ Built js/libs.min.js

Building frappe assets...

✔ Built js/dialog.min.js
✔ Built js/modules.min.js
✔ Built js/social.min.js

Any ideas on how long this should take or how I can speed it up? Previously on v11 it took a while but would eventually build. Now it’s not going at all…



bench clear-cache
bench update --build
NOT with sudo

Hope it helps.

Whoa!!! This is awesome… I almost feel like a kid in a candy store :blush:

Did this ship with the DB API as planned? Didn’t see anything about that in the release notes


I’m up and running! Needed to increase my VM on GCloud as my ram was too low. Now it seems to be working smoothly. Thanks

1 Like

As of now.

~/frappe-bench/apps/erpnext$ git branch -a

  • develop
    remotes/upstream/HEAD → upstream/develop

~/frappe-bench$ bench switch-to-branch v12 erpnext
Switching for erpnext
INFO:bench.utils:git config --unset-all remote.upstream.fetch
INFO:bench.utils:git config --add remote.upstream.fetch ‘+refs/heads/:refs/remotes/upstream/
INFO:bench.utils:git fetch upstream --unshallow
remote: Enumerating objects: 1, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 1 (delta 0), reused 1 (delta 0), pack-reused 0
Unpacking objects: 100% (1/1), done.
INFO:bench.utils:git checkout v12
Branch v12 set up to track remote branch v12 from upstream.
Switched to a new branch ‘v12’
INFO:bench.utils:git merge upstream/v12
Already up-to-date.
Successfully switched branches for:
Switched to v12
Please run bench update --patch to be safe from any differences in database schema

v11 running in VM box
Trying to upgrade to V12
when i run this
frappe@ubuntu:~/frappe-bench$ git config remote.upstream.fetch “+refs/heads/:refs/remotes/upstream/
i get error
fatal : not in a git directory
how to resolve this

Hi Kirishnan,

Check this link out. That should resolve your issue. Hopefully. The software behind this forum replaces some of the characters, that’s the problem.



Thanks for the reply
this command
git config remote.upstream.fetch “+refs/heads/:refs/remotes/upstream/”
iam running @ frappe@ubuntu:~/frappe-bench$
should i change the directory to git
if so how

how to execute this command
“What do you see if you go to frappe-bench/apps/erpnext and do a git status?”
should i change the directory from frappe@ubuntu:~/frappe-bench$ to ?
Thanks and regards

1 Like