[Release Notes] ERPNext and Frappe Version 13.11.0

As @ankush said bench update or if manually you can bench setup requirements. This is an issue with redisearch missing because new packages were not installed from requirements.txt

Error when trying to run Install / Update install-app erpnext

An error occurred while installing erpnext: unknown command ‘MODULE’


Perhaps try bench get-app erpnext , then install-app …, or bench-update --reset

We have fixed this issue, could you please pull the latest version and check

1 Like

Getting this error when trying to update for 13.11.0

Traceback (most recent call last):
File “/home/bench/frappe-bench/apps/frappe/frappe/model/base_document.py”, line 358, in db_insert
frappe.db.sql(“”"INSERT INTO tab{doctype} ({columns})
File “/home/bench/frappe-bench/apps/frappe/frappe/database/database.py”, line 147, in sql
self._cursor.execute(query, values)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/cursors.py”, line 148, in execute
result = self._query(query)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/cursors.py”, line 310, in _query
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/connections.py”, line 548, in query
self._affected_rows = self._read_query_result(unbuffered=unbuffered)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/connections.py”, line 775, in _read_query_result
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/connections.py”, line 1156, in read
first_packet = self.connection._read_packet()
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/connections.py”, line 725, in _read_packet
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/protocol.py”, line 221, in raise_for_error
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/pymysql/err.py”, line 143, in raise_mysql_exception
raise errorclass(errno, errval)
pymysql.err.IntegrityError: (1062, “Duplicate entry ‘panaracer-gravelking’ for key ‘PRIMARY’”)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/lib/python3.8/runpy.py”, line 194, in _run_module_as_main
return _run_code(code, main_globals, None,
File “/usr/lib/python3.8/runpy.py”, line 87, in _run_code
exec(code, run_globals)
File “/home/bench/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 104, in
File “/home/bench/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 19, in main
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 829, in call
return self.main(*args, **kwargs)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 782, in main
rv = self.invoke(ctx)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 1259, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 1259, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 1066, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 610, in invoke
return callback(*args, **kwargs)
File “/home/bench/frappe-bench/env/lib/python3.8/site-packages/click/decorators.py”, line 21, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/bench/frappe-bench/apps/frappe/frappe/commands/init.py”, line 27, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/bench/frappe-bench/apps/frappe/frappe/commands/site.py”, line 306, in migrate
File “/home/bench/frappe-bench/apps/frappe/frappe/migrate.py”, line 67, in migrate
File “/home/bench/frappe-bench/apps/frappe/frappe/modules/patch_handler.py”, line 41, in run_all
File “/home/bench/frappe-bench/apps/frappe/frappe/modules/patch_handler.py”, line 30, in run_patch
if not run_single(patchmodule = patch):
File “/home/bench/frappe-bench/apps/frappe/frappe/modules/patch_handler.py”, line 71, in run_single
return execute_patch(patchmodule, method, methodargs)
File “/home/bench/frappe-bench/apps/frappe/frappe/modules/patch_handler.py”, line 91, in execute_patch
frappe.get_attr(patchmodule.split()[0] + “.execute”)()
File “/home/bench/frappe-bench/apps/erpnext/erpnext/patches/v13_0/create_website_items.py”, line 56, in execute
File “/home/bench/frappe-bench/apps/frappe/frappe/model/document.py”, line 285, in save
return self._save(*args, **kwargs)
File “/home/bench/frappe-bench/apps/frappe/frappe/model/document.py”, line 307, in _save
File “/home/bench/frappe-bench/apps/frappe/frappe/model/document.py”, line 253, in insert
raise e
File “/home/bench/frappe-bench/apps/frappe/frappe/model/document.py”, line 250, in insert
File “/home/bench/frappe-bench/apps/frappe/frappe/model/base_document.py”, line 376, in db_insert
raise frappe.DuplicateEntryError(self.doctype, self.name, e)
frappe.exceptions.DuplicateEntryError: (‘Website Item’, ‘panaracer-gravelking’, IntegrityError(1062, “Duplicate entry ‘panaracer-gravelking’ for key ‘PRIMARY’”))
INFO: A newer version of bench is available: 5.4.1 → 5.6.0

It seems you have a duplicate entry on your database. Try cleaning it up:

Thanks @rohit_w. That allowed me to update. I am getting the No module named ‘erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings’ error tho

Thanks mate, just completed an update v13.11 without any more issue.

i have the same error:

Failed to get method for command erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings.is_cart_enabled with No module named ‘erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings’

@elkinleon @cacarios

Hey this looks like a build issue. The stale built js assets are still considered. Try rebuilding and check again.
If it still breaks (hack) maybe empty the contents of the sites/assets/js folder and run bench build again

1 Like

Hello there

In the wake of Upgrading : I get this blunder when signing in -

Neglected to get strategy for order erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings.is_cart_enabled with No module named ‘erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings’


I am getting this error , did some research talking about a swap file, however this is not a first update i am doing, I have reboot the whole instance to clear data sitting in memory… any tips.

Built js/checkout.min.js
:heavy_check_mark: Built js/dialog.min.js
error Command failed with exit code 137.
info Visit yarn run | Yarn for documentation about this command

Request you to share the step query the duplicate entry.

tried this didn’t work , had to do a fresh install, lucky it was my test system not production … yet to update production

Any solution to this? Have same error at each time I login

We had the same issue after migration. We were actually getting the error because of a custom app that referred to “Shopping Cart Settings”, which was renamed to “E Commerce Settings” with the recent refactor.

I don’t know if that’s the only way to see this error, but noting it here in case someone else has a custom app installed that uses the Shopping Cart Settings doctype.

In Shopping Cart folder, add .py,.js and .json file.
Then bench migrate and bench restart.

@marination Thanks for your advice. I emptied js folder and bench build but did not remove the error message.What else can we do to remove this nagging notification "Failed to get method for command erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings.is_cart_enabled with No module named ‘erpnext.shopping_cart.doctype.shopping_cart_settings.shopping_cart_settings’'.

@marination .Thanks.It works perfectly after I cleared the cache.The nagging message is gone.Thanks

Thanks, works perfect!

1 Like