[Release Notes] ERPNext Version 13 has been released

Were you able to resolve this issue?
I am having the same issue.

In my opinion, this is ok for an open source product. The more people use it the more bugs will be discovered and eventually addressed.
The problem is to jump to new versions without knowing and understanding what the risk are. I saw people even rushed to version-13-beta for production.
For me, I don’t update production until 2 or 3 minor version update. I will wait until v13.2 or 13.3 at least before update my production.
I will hold myself to the temptation of the sleek new UI and features :grinning:
Just my 0.02…


I am facing the same issue. Did you find any fix for it…Need help

But you’re making those decisions based on a significant amount of experience. People new to the product do not know these things, so if their first experience is extremely bad, which in this case it will be, they will go somewhere else.

Open-source or not, it is still a professional paid team producing a supposed professional product that they expect businesses to use on a day-to-day basis without any development knowledge. This release simply is not that.

So it is never okay if you want the product to succeed.

The team needs to get a lot better at writing tests, testing, fixing bugs and releasing only when ready.


I don’t know what can solve that.

Try clearing website storage and cache.

thanks for replying :slight_smile:

Half of the phrases are untranslatable. I checked multiple languages. Is there something we can do to help fix this? I am willing to work on this, but need someone to point me in the right direction…

For example, this looks like it should work, but it doesn’t:

“{0} edited this {1}”

wow … all done and enjoying new UI-V13


Classical chicken or the egg problem, which one comes first ?

If enough people do not use the new version in production environment how will the kinks be worked out?

If everyone took your approach no one will discover the bugs and we will all be waiting for the “other” people.

I understand your position, it is logical, however try not to rub it in the face of the people that will help make the application better for you…they may just decide to wait too. Just like you.

1 Like

This fixed the translation problem. Its one line fix that solves translations problem. Shouldn’t this be merged?

Thanks for your honest feedback!

It’s true, we need to do more testing before a production release.

But it’s also true, all these reported issues are related to the migration of existing accounts and in most cases, related to data. The new user will not get these issues. And we have tried to migrate 3-4 existing users database before the production release, all these issues did not appear there.

All these codes were available there in develop branch and in the beta release, so any community member could migrate to develop/beta branch and report those issues beforehand. But it did not happen.

I am not blaming anyone, but it’s the responsibility of the entire community to test those and report in advance. That makes a successful open source community.

By the way, we are working to fix all the reported issues in patches, will take a release tomorrow. We already fixed issues related to frappe and released it today.


I have made several installations this way, and never seen a message about bench running in development mode.
Did you mean warning, that bench runs in editable mode?

yes “runs in editable mode”

you can choose Toggle Side Bar

Thank you very much for your efforts ,
we want to know when will update ERPNEXT VM to V13?

Should step 5 be…

python3 install.py --verbose --production –frappe-branch version-13 --erpnext-branch version-13 --user frappe

If you want to run stable production v13 release and not beta?

1 Like

Hello everyone.

My sequence with the update:

sudo apt update
sudo apt upgrade
curl -fsSL https://deb.nodesource.com/setup_10.x | sudo -E bash -
sudo apt-get install -y nodejs
sudo npm install -g npm
sudo npm install -g yarn
cd / opt / erpnext / erpnext
bench setup requirements
bench update
sudo reboot
bench switch-to-branch version-13 frappe erpnext --upgrade


File “/opt/erpnext/bench-repo/bench/app.py”, line 417, in switch_to_branch
switch_branch (branch, apps = apps, bench_path = bench_path, upgrade = upgrade)
File “/opt/erpnext/bench-repo/bench/app.py”, line 409, in switch_branch
reload_module (utils)
NameError: global name ‘utils’ is not defined

I have followed these steps, but in the file /opt/erpnext/bench-repo/bench/app.py, prior to the update and the error has not appeared in a new update.

However now this appears:

File “/opt/erpnext/erpnext/apps/frappe/frappe/website/doctype/website_theme/website_theme.py”, line 69, in generate_bootstrap_theme
self.theme_scss = content = get_scss (self)
File “/opt/erpnext/erpnext/apps/frappe/frappe/website/doctype/website_theme/website_theme.py”, line 145, in get_scss
apps_to_ignore = tuple ((d.app + ‘/’) for d in website_theme.ignored_apps)
AttributeError: ‘WebsiteTheme’ object has no attribute ‘ignored_apps’

1 Like

V13 is broken on Android and iOS apps. The app is crucial for us.

1 Like

after issuing command
bench switch-to-branch version-13 frappe erpnext --upgrade
then attempting to run bench update I get the following error

$ bench update

Traceback (most recent call last):
File “/usr/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 489, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2793, in load_entry_point
return ep.load()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2411, in load
return self.resolve()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2417, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/home/frappe/.bench/bench/cli.py”, line 3, in
from bench.utils import is_root, PatchError, drop_privileges, get_env_cmd, get_cmd_output, get_frappe, log, find_parent_bench
File “/home/frappe/.bench/bench/utils.py”, line 23, in
import requests
File “/usr/lib/python2.7/site-packages/requests/init.py”, line 43, in
import urllib3
File “/usr/lib/python2.7/site-packages/urllib3/init.py”, line 10, in
from .connectionpool import (
File “/usr/lib/python2.7/site-packages/urllib3/connectionpool.py”, line 31, in
from .connection import (
File “/usr/lib/python2.7/site-packages/urllib3/connection.py”, line 45, in
from .util.ssl_ import (
File “/usr/lib/python2.7/site-packages/urllib3/util/init.py”, line 5, in
from .request import make_headers
File “/usr/lib/python2.7/site-packages/urllib3/util/request.py”, line 5, in
from …exceptions import UnrewindableBodyError
ImportError: cannot import name UnrewindableBodyError

Did you find any solution for this error? I am also stuck with this error.