[Release Notes] Frappe & ERPNext Version 13.0.0 Beta.1 Released!

I‘ll try that for sure


During login, after switching branch to version-13-beta

Is there a way to contribute to the release notes? I am missing some new features.

Same Issue with me Invalid version string: ‘13.0.0.beta.1’

If you close the error, and refresh the browser, you can access the system. Short term solution.

1 Like

@glz, @Akram_Mutaher The issue has been fixed with

Please pull the latest commit for both Frappe and ERPNext using git pull cmd.

1 Like

Facing this error:

PS C:\Users\user\frappe_docker> docker-compose
–project-name frappebench00
-f installation/docker-compose-common.yml
-f installation/docker-compose-erpnext.yml
-f installation/erpnext-publish.yml
up -d
At line:2 char:7

  • --project-name frappebench00 \
  •   ~

Missing expression after unary operator ‘–’.
At line:2 char:7

  • --project-name frappebench00 \
  •   ~~~~~~~~~~~~

Unexpected token ‘project-name’ in expression or statement.
+ CategoryInfo : ParserError: (:slight_smile: [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : MissingExpressionAfterOperator

This is a script that runs daily


Doesn’t seem to fail here Travis CI - Test and Deploy Your Code with Confidence

Check the syntax, command?

Looking at C:\Users\user\frappe_docker>. You’re on windows.

You copy pasted bash script into windows terminal

I don’t have windows machine to copy paste same thing into windows terminal and debug this for you.

If I get access to window machine, I’ll try to solve this.

Edit: I made the commands copy paste friendly. If it doesn’t work on windows try replacing forwardslash (/) with backslash (\) for directory separator. Check how it is in C:\Users\....

did you miss last command?

docker run -it -e "SITE_NAME=v13beta.localhost" -e "INSTALL_APPS=erpnext" -v frappebench00_sites-vol:/home/frappe/frappe-bench/sites --network frappebench00_default frappe/erpnext-worker:v13-beta new

I skipped the last command and I saw the “don’t panic” page.

Then I ran the command and saw output with progress bar that creates new site and installs erpnext.

❯ docker run -it -e "SITE_NAME=v13beta.localhost" -e "INSTALL_APPS=erpnext" -v frappebench00_sites-vol:/home/frappe/frappe-bench/sites --network frappebench00_default frappe/erpnext-worker:v13-beta new
Created user _0e393b398cde8a24
Created database _0e393b398cde8a24
Granted privileges to user _0e393b398cde8a24 and database _0e393b398cde8a24
Starting database import...
Imported from database /home/frappe/frappe-bench/apps/frappe/frappe/database/mariadb/framework_mariadb.sql

Installing frappe...
Updating DocTypes for frappe        : [========================================]
Updating country info               : [========================================]

Installing erpnext...
Updating DocTypes for erpnext       : [========================================]
Updating customizations for Address
Updating customizations for Contact
*** Scheduler is disabled ***

Then I was able to view app on url http://v13beta.localhost

https://github.com/frappe/frappe_docker/blob/develop/tests/docker-test.sh#L69 this test pings new created site for success response. It’s not failing. I am able to create and access site, Test is able to create and ping the site.

I use gnu/linux. Not any time soon I’m going to get access to windows machine. It is just a guess work for me.

Nope i didn’t miss the command. I ran it. But just to be sure i tried to run it again and it says site already exists.

Sorry, I can’t help you. I’m just FOSS enthusiast maintaining frappe_docker repo. I just get thrill and fun out of it. Nothing else.

Please don’t take ERPNext Version Released post off-topic. You can post here Issues · frappe/frappe_docker · GitHub

Note: Travis CI - Test and Deploy Your Code with Confidence again the job passed without errors.

1 Like

I tested on mac. It works perfectly. I just followed the instruction line by line on terminal.

Thank you so much @revant_one for your contribution and effort.

Others who are trying to get erpnext on a mac using docker please make sure that docker and docker-compose is installed and follow the instruction on terminal

Please note Docker Desktop for Mac already include Compose

Version 13 is amazing. Great work frappe and erpnext team. Lots of major features are updated exploring one by one.


Not disputing your contribution or anyone else’s for that matter. Your effort is appreciated by all. My attempt to install frappe_docker in windows has obviously shown you it needs to be optimized for windows as well so i don’t think overall it’s a worthless attempt.

Withdrawn all posts about docker.

Trying to install the beta is however not off-topic as everyone was encouraged to install and test. But like i said, for non-developers like me, we’re better off staying away from these conversations even though our unique perspectives and user experience is vital for the overall development of software and applications as we constitute over 90% of the user base.

1 Like

Hey guys. This is awesome. Been expecting something of this magnitude and it seems you’ve beaten expectations. The social media posting is interesting. Is there any plan to do Facebook and/or Insta in future?

I don’t see the mention of the immutable ledger. I thought it was being introduced in v13.

We need a pinned post to explain users the difference between open source software codes and support. I am sure we all get messages asking for support and then when they get ignored they blame it on the software for not getting enough support.
A post that explains them that support is not Free like the source code is badly needed. Yesterday I gave back to a guy on twitter so I think it is better to have an official post with detailed explanation about foss source code and asking for help as free support.

Sorry for going off topic :wink:


Hi. Unfortunately, it doesn’t work for me. Please see attached screenshot. Could you help, please?

Please add issue, I’ll check Sign in to GitHub · GitHub

docker knowlege is required. Only copy paste will not help when things don’t work.

Still no better way of business expense entry?