Remove decimals for currency

I want to change the format of a currency to #,###. I changed it under the currency doctype but the format is still not adjusted in other doctypes (e.g. Purchase invoices). What do I need to do to get it working?


There is also Currency Precision in Settings, System Settings.

Thanks. Yes, I know. This is however not the right solution in my case. I have a multi currency setup and want to remove the decimals for one of the currencies only. It’s confusing that the setting in the currency doctype doesn’t work. Or is there anything else I need to do?

I don’t see anything in the UI that would provide it, other than what you have tried. For print formats, you might be able to use some sort of conditional logic in the Jinja code.

Mh. Yes. That might be possible fixing it manually with Jinja.
Does that mean that this is dead code? Or did it maybe work before and was messed up?
I think it’s probably a similar problem for people with a multi-currency setup working in e.g. German speaking countries (where the comma is used as decimal separator).

Did anyone else ever managed to use different individual currency formats (not via the global system settings)?

Nope. Somehow I tried and tried and tried, but the individual currency formats would never work. Like what you mentioned, I think it is most likely dead code.


Maybe related?