Remove orphaned app

I have tried several removal command and deleted it from the sites/apps.txt and it always says there is no app installed I also followed this reference:

Yet here is the trace back I get now when I do a bench update I would like the s3_backup app gone:
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 217, in migrate
migrate(context.verbose, rebuild_website=rebuild_website)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 31, in migrate
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 27, in run_all
for patch in get_all_patches():
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/”, line 48, in get_all_patches
patches.extend(frappe.get_file_items(frappe.get_pymodule_path(app, “patches.txt”)))
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 738, in get_pymodule_path
return os.path.join(os.path.dirname(get_module(scrub(modulename)).file), *joins)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 700, in get_module
return importlib.import_module(modulename)
File “/usr/lib/python2.7/importlib/”, line 37, in import_module
ImportError: No module named s3_backup

Have you tried bench uninstall-app (you’ll need to supply the arguments)
Followed by bench remove-app? Bench must be running during this step, which is weird and counter-intuitive but I’ve tried it enough times to know that it’s required

Bench Sheatsheet

was able to get this command to run without error:
bench remove-from-installed-apps s3_backup

but not this command bench uninstall-app s3_backup

the presence of s3 backup under setup/integration is now gone but remains under the integration button in desk.

bench remove-app s3_backup
No app named s3_backup

Thank you… progress but am still unclear why s3 backup shows in desk integrations if it is uninstalled and why my data is still there but when I select take backup now it says started but does not complete?

You may have to delete the folder under frappe-bench/apps
There other problems are likely to go away after you do so and run bench migrate and then restart

You can try this.


Create a new app s3_backup with description S3 backup


bench remove-from-installed-apps s3_backup

then try bench uninstall and remove app

Is s3 backup this supposed to be here natively or is this something that got installed and did not uninstall if its supposed to be here it does not work it just sit there and no interaction with amazon:

It was added to core

ok well I have put in all the appropriate information it is not saving to s3 yet it does create the bucket under my account???

What logs should I look at for where this is failing as its not showing up in the customary logs?

Filed a bug on this S3 Backup create bucket on Amazon s3 but does not add files. · Issue #15261 · frappe/frappe · GitHub