Rename an item- not permitted

I am trying to rename an item but I am getting a message - Not permitted. I am the admin and I have full user access. can someone please help.

Hii @gurdeep_sahani,

Welcome to Forum

Please share your image of error.

Thank You!

thanks for your reply. please see attached image. 16%20PM

Hi @gurdeep_sahani,

It’s may be edit right problem.
So check role permission for item master.

Thank You!

If he is logged in as Admin then he should have a full access.

Can you please post the screenshot of selected roles of your logged in user?

yes. I have access to all roles. please see the screenshot of my roles assigned.
please can you advise ? ![36%20PM|636x266]36%20PM

check in DocType or Customize form whether rename under autoname section is enabled for the doctype.

allow rename is ticked. I used to use it about 6 months or so ago. NO settings have changed for me. suddenly it has stopped working.

Any recent bench updates after which the issue started?

hello. I dont know what the bench updates mean. I havent updated my system at my end. please can you help on how to resolve this. I think it is a glitch in the system.

I would help for sure but need to know more inputs. Check for any error logs and see if you can find anything there.

Also try to create a new user with full access and see if the same problem is there with that user as well.

please advise where I can find the error logs.

Can you tell us what are you trying to rename?

I am trying to rename an item. and merge it with an existing item

Does both items have same attributes like same UOM, stock item, batch/serial no. expiry. If it does not have then you cannot rename and merge the items.

You can type error log list in search bar

ok so I renamed it to a completely new number and it is still showing the same message. I think it is more to do with user permissions as it says not permitted. I tried looking at the error logs but nothing showing up there

Did you check this?

I checked it and it has same attributes. to avoid a mistake instead of merging I tried giving it a completely new number. and I am getting the same message. so its not a mistake of attributes not matching

Hi, did you resolve this? I am suddenly having the same issue. Looks like permissions for renaming items have been changed.