Renaming tool not working

When trying to rename around 450 Items in the hosted version of ERPnext I get to the screen, insert my CSV, upload the file and click on rename. Afterwards, the screen says “Renaming…”. This message never disappears though and the items are not renamed.


I have checked on latest version and it’s working properly. It seems that there is an issue with your CSV file, there should be only two columns in which old names in first column and new name in second column. Also remove the blank rows and columns from the CSV file.

worked for me too just yesterday

@rohit_w I copied everything into an editor window and tried again saving it as a csv file. I check that there are only two rows separated by a semicolon and no space at the bottom. Still same result. Tried the same with a comma separated file → same result

Please check my file:

It is difficult to find errors here as there is no error message in the tool,

Problem solved: Reloading cache + replacing all semicolons with commas fixes the problem

I suggest specifying this in the text below the file selector or allowing for multiple types of separators.

It is a big pain to change the default csv separators on windows as you have to edit system settings and cannot specify it in excel.