Report not showing on the browser but shows on the mobile app

When I run item-wise sales report or any report, it shows me blank page. However, when I run the same report on the mobile app I get the report.

Can someone please help?

What browser are you using? Do you have output in the browser console?

I am using Firefox and Google Chrome. Please find below the link for browser console. I could not upload images.

Browser Console

Thanks.

If you are self hosted erpnext then run following:

su - frappe -s /bin/bash # change to your frappe OS username, if different.
cd ~/frappe-bench/
bench clear-website-cache

From Desk once logged in as Administrator, Click on Reload from Users Manu in Top Navigation bar next to Help Menu.

Something more to share with you. Following are some actions I took.

  1. Cleared the Browser Console
  2. Logged in to ERPNext (self-hosted)
  3. Run the required report
  4. extract new data from the browser console

By the way, we do not have SSL installed at the moment. could this also be a reason.

Following is what I got

Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.[Learn More] login

[Show/hide message details.] TypeError: $event.fixHooks is undefined report.min.js:3041:2

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/ jquery.min.js:2:79417

OpenGL compositor Initialized Succesfully.
Version: 2.1 INTEL-10.36.19
Vendor: Intel Inc.
Renderer: Intel(R) Iris™ Graphics 550
FBO Texture Target: TEXTURE_2D

Those are warnings you may ignore those for now.
Most of errors are maybe due to your Chrome Plugin/Extensions.

don’t clear just browser console, do what I shared in earlier post.

We have done that according to the instructions but we are facing the same problem.

Anybody please help…

Next time if anyone has a problem.

Please make a new instance install ERPNext (beta instance). copy files ‘jquery.min.js’ and ‘report.min.js’ from “beta instance” and paste in your original ERPNext self-hosted instance.

It works.

Found the solution.

Hi @Majid_Ejaz,

thanks for sharing. This would indicate an issue with the script files. Rather than copying, rebuilding the files should also resolve it:

$ bench update --build
2 Likes