Request Timed Out - Error on Salary Slip Submission

Hello, I have an error on submitting salary slip
When I submit salary slip it takes too long to load then it pops up an error, Request timed Out.
Even if I submit just 1 salary slip the request times out.

But when I disable the option “Email Salary Slip to Employee” in >> “HR Settings”, Salary slip submits within seconds,

Now I still need the email to be sent to employees about their salary slip, so I want to solve this without disabling sending of email. Email domain is working fine because all other emails from the system are being sent without any difficulty.
I have tried “bench reinstall”, then restoring my database but the error is still there.
Also tried “bench switch-to-develop” then reversed back to master but the error is still there.

I am running ERPNext: v10.1.53 (master) and Frappe Framework: v10.1.48 (master) hosted in digitalocean ubuntu 16.04

Kindly help me

How much RAM do you have on the droplet?

RAM is 2GB.

Some patch seems to be missing or some backend service failing.


bench retry-upgrade
bench update --patch
bench migrate

if issue still persists, then

bench setup config
bench setup socketio
bench setup supervisor
bench setup nginx
bench restart

Let all config refresh and checkout if it fixes the problem.

if that does not resolve then share your logs for following by uploading it to pastebin or similar service:

tail 100 ./frappe-bench/logs/node-socketio.error.log
tail 100 ./frappe-bench/logs/redis-cache.error.log
tail 100 ./frappe-bench/logs/web.error.log
tail 100 ./frappe-bench/logs/worker.error.log
tail 100 ./frappe-bench/logs/schedule.error.log
1 Like

I have done the above but the error is still there.
here are the error logs

./frappe-bench/logs/node-socketio.error.log link

./frappe-bench/logs/redis-cache.error.log is empty

“./frappe-bench/logs/web.error.log” and “./frappe-bench/logs/worker.error.log” are quite huge. couldn’t paste them but here is the upload. << LINK REMOVED >>

./frappe-bench/logs/schedule.error.log link is


Your log shows, redis is not running or failing to start or not installed.

Error: Redis connection to localhost:12000 failed - connect ECONNREFUSED

To Reinstall Redis and do following:

bench setup redis
bench setup config
bench restart

Solved your issue?


Thank you,
I reinstalled redis but the error was still there.
so I ran supervisorctl stop all and then bench start and the problem was solved. I can now submit salary slip and also send email to employees about their salary slip.
Thank you very much sir for your assistance.
I had been struggling with this for more than 3 months. :slightly_smiling_face: