Resource not found Error

i did a bench update and iam running on ERPNext: v8.0.47 (master) version
After the bench update, i am not able to print any docs.
the error i get is

"Not found

The resource you are looking for is not available"

when i remove the “letter Head” option then it gives the following error
“Page Missing or Moved
The page you are looking for is missing. This could be because it is moved or there is a typo in the link.”

when i press the “pdf” button, it prints in pdf

I dint have this error previously
Please help

The issue is with printing of reports or all the doctype like sales order, purchase order etc.

Hi ArundhatiS
Thanks for responding
The issue is with printing of any or all docs
for example
i create an RFQ
i input all details
then i press the “print” icon
its returns the above error
it throws up an blank page

on the right hand top, i have 4 options…print…customise…full page…pdf
when i press the pdf, it prints in pdf format

this is happening to all doc types

Can you check if Roles assigned to you also covers Print permission on the DocTypes? Which browser are you accessing your ERPNext account from? If you have another test account, is this issue replicating in it? If yes, then whats the different in both of these accounts? Also check if issue is related to local configurations like Java Script disabled in the browser etc.

Hi Umair
Thanks for the suggestion
I tried it on Ms Edge, firefox, Chrome
The error throws up on all these browsers
Roles assigned have full access
I tried it in a different system and the error still remains.

As i said, iam able to get a print when i use the PDF option
But when i click the print icon, it throws up a blank page with error
This started happening after i did a bench update
i updated the bench again a couple of times but the error is still there
Thanks Again

i facing the similar issue, did you solve it?

Hi Gavin_Ji
I coudnt solve the issue
I ended up installing a fresh instance
Thanks and Regards

Admin can close this Topic