REST API POST request returns 200 response but didn't edit the item

Hi all,

I try to edit an item via the REST API of ERPNEXT. However, I keep getting the same response code (200) and the request doesn’t edit the item. GET requests are working fine. However, the POST request just returns all the values of the Item, without editing the value it should have edited. See image:

Does anybody know what I’m doing wrong here?


Did you find a solution @Rick_Adriaensen ??

For updates you should be doing PUT

I have been following your tutorial here REST API ( @ankush

When I do a POST request, it responds with <response 200> but do not create the new file to the system. When I try the same thing on my local site, it works completely fine.

Are there any special permissions or setups required to initiate the api for cloud? (Even giving all permissions do not work for me). What would I be doing wrong?

Actual (response.text) from terminal
{‘Date’: ‘Mon, 21 Nov 2022 15:38:47 GMT’, ‘Content-Type’: ‘application/json’, ‘Transfer-Encoding’: ‘chunked’, ‘Connection’: ‘keep-alive’, ‘Vary’: ‘Accept-Encoding’, ‘Set-Cookie’: ‘sid=Guest; Expires=Thu, 24 Nov 2022 15:38:47 GMT; Secure; HttpOnly; Path=/; SameSite=Lax, system_user=no; Secure; Path=/; SameSite=Lax, full_name=Guest; Secure; Path=/; SameSite=Lax, user_id=Guest; Secure; Path=/; SameSite=Lax, user_image=; Secure; Path=/; SameSite=Lax’, ‘X-RateLimit-Reset’: ‘48073’, ‘X-RateLimit-Limit’: ‘3600000000’, ‘X-RateLimit-Remaining’: ‘3570497812’, ‘X-RateLimit-Used’: ‘38073’, ‘X-Frame-Options’: ‘SAMEORIGIN’, ‘Strict-Transport-Security’: ‘max-age=31536000; includeSubDomains; preload’, ‘X-Content-Type-Options’: ‘nosniff’, ‘X-XSS-Protection’: ‘1; mode=block’, ‘Server’: ‘Frappe Cloud’, ‘Referrer-Policy’: ‘no-referrer-when-downgrade’, ‘X-Proxy-Upstream’: ‘http://52b0087a6166eb63’, ‘Access-Control-Allow-Origin’: ‘https://{mysitename}’, ‘Access-Control-Allow-Headers’: “'Origin, Content-Type, Accept”, ‘Access-Control-Allow-Credentials’: ‘true’, ‘Access-Control-Allow-Methods’: “'GET, POST, OPTIONS”, ‘Content-Encoding’: ‘gzip’}