Restore backup issue for erpnext V11

I am trying to do a backup restore to my erpnext instance (V11), but getting the below error…
Command used: frappe-bench$ bench --site site1.local --force restore backup_file

Can you please help.


You should not run these commands as user “root” - it causes permissions problems.
Rather run as user frappe

Thanks trentmu for the response.

But with frappe user also getting the same error.

Have you tried to do the restore a V11 sql file in another V11 erpnext installation.

Waiting for your response.


Hi, I was also looking for something similar and that’s why I ended up here ( I would definitely try to restore the V11 sql file but I guess that won’t alone help as I am getting 2 other errors that I checked up here.

i think you didnt install ERPNext App before you restore DB.

I think perhaps you did the install as user root, and then the restore as user frappe. You should do both as user frappe

1 Like

I have done easy install…used the below command

$sudo python --production --user frappe

have you tried to do the restore for V11 successfully.

ERPNExt was installed successfully and we were able to access and setup new company also.

Its just after running the restore command things got messed up with the above error message and then were not able to access the application also.