Restore from backup - it works, but the process had some issues

Hey guys, I tried to restore an ERP instance here on a new Ubuntu installation.

It worked - I can login and use it, but I got some errors in the restore process.
Should I worry? I don’t really understand the error messages.

Why do I get the password error on the last line (the mysql root pasword is correct)?

bench frappe --restore site1.local /tmp/20150219_9038569_database.sql site1.local --force

MySQL root password: 
Created user 1bd3e0294d
Created database 1bd3e0294d
Granted privileges to user 1bd3e0294d and database 1bd3e0294d
Starting database import...
Imported from database /tmp/20150219_9038569_database.sql
Traceback (most recent call last):
  File "/home/sup3r/frappe-bench/env/bin/frappe", line 9, in <module>
    load_entry_point('frappe==4.12.1', 'console_scripts', 'frappe')()
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 53, in main
    return run(fn, parsed_args)
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 81, in run
    out = globals().get(fn)(*args.get(fn), **args)
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 67, in new_fn
    return fn(*args, **new_kwargs)
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 386, in restore
    _install(db_name, source_sql=source_sql, quiet=quiet, force=force)
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 317, in _install
    admin_password = admin_password, verbose=verbose, force=force, site_config=site_config, reinstall=reinstall)
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 39, in install_db
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 71, in create_auth_table
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 162, in sql_ddl
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 479, in commit
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 79, in sql
  File "/home/sup3r/frappe-bench/apps/frappe/frappe/", line 49, in connect
    use_unicode=True, charset='utf8')
  File "/home/sup3r/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 81, in Connect
    return Connection(*args, **kwargs)
  File "/home/sup3r/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 193, in __init__
    super(Connection, self).__init__(*args, **kwargs2)
_mysql_exceptions.OperationalError: (1045, "Access denied for user 'site1.local'@'localhost' (using password: YES)")


The command you should have put,

bench frappe --restore 1bd3e0294d /tmp/20150219_9038569_database.sql site1.local --force

@pdvyas Ah, thank you very much. I thought that the DB_NAME was arbitrary.

Can I run --force again or do I have to make a clean install?

Yes, you can run with --force again