Restore not working with latest update


I am trying to move my demo site to a different system. So I created a new bench/site and restored the database. The restore itself worked fine, however logging in a ‘Administrator’ says ‘The resource you are looking for is not available’. I can’t even check roles as it gives the same error there as well.
To troubleshoot this further, I created a new bench/site and started the initial setup wizard. That failed as usual with ‘There were errors’ message. In earlier attempts, that used to heal itself after 2-3 attempts and bench restart. However this time it cam back with more specific errors like ‘Duplicate Name Salary Component Basic’, ‘Program code is required’. Looks like something is wrong with bench update…


OK, I switched to firefox from Chrome and the issue magically disappeared. Looks like the Administrator chrome managed to sign in isn’t really the Administrator! Is there any logs I could see to confirm the same?

I think simultaneous logins are blocked by default. Just seems an issue of logging in from different windows / browsers.