Restricting workspace management for a user role

I need help with restricting workspace management for a user role like hiding the “Add Workspace” and “Edit” button from their logged in Frappe desk

a user without the role of System Manager not allowed to modify the workspace

1 Like

Hi @Sanya,

Remove the workspace manager right from a user and then check it.

Thank You!

1 Like

Hi @NCP , I’ve tried this and it doesn’t remove the workspace options for my test account. I’m using v14. Any idea why this may be?

It only displays “Create Workspace” and Edit option but doesn’t allow the user to Create or Edit.

Right @Sanya.

However It is allowing user to create private workspaces and link any doctype and save despite not having a Workspace Manager role. Using v15. User is not able to edit the public workspace, if they change they can only discard changes, however they can create new private workspaces.