Role Permission Error

Hi there,

I m facing an issue regarding role permission manager after updating to version 8.
I m trying to remove some accesses for a role but it doesn’t happen properly.
Also sometimes multiple permissions appear for a single doctype.
If you need Screenshots let me know.

After Update unable to set role permissions.

Hi @Ujjawal ! Could you send us some screenshots of what you are referring to?

I’ll elaborate as well.

As you can see there are blank Document type which Cannot be removed

The error received while trying to remove the blank doctype permission

Moreover when trying to remove permission for a doctype, I am unable to do so.

Also when a user trying to access a module, the system throwing an error as no permission to access this resource.
Even though he has been provided the permissions.
He can access a Doctype by directly opening from Search bar but cannot open a module.
I’ll paste the screenshot for the same.

did you make any customization in role permissions?

I made customizations in role permissions but still I must be able to remove for a particular doctype if not for blank ones.

Also tried resetting the permissions but still no luck with that.
The blank doctypes still appear.

can you share what custmization you done ?

Customization, as in what?
I have added a field as If Assigned in Role permissions.

Hello @Ujjawal, did you customize Role Permissions by adding a script ? If yes, can you post the script here?

Thanks! :slight_smile:

No Not through script.
Directly edited the doctype and added the field.