Running ova on synology vmm


has someone successfully installed the frappe/production image on synology vmm?

i do not have access via browser.
ifconfig eth0 only told me “device not found”.
i also can´t ping any ip in my network, i searched a lot but didn´t find any solution.

syno rs818+
lan 1,2,3,4 connected with static ips
host lan1
vm lan4

2 cpu, 2gb ram, vga, rtl8139

maybe someone has successfully tried and can support a little.
i tried a clean ubuntu and get a normal ip address, but i can´t get frappe working in my network.

i asked already on git frappe/erpnext , they refer to this forum.

thanks a lot!

some time ago I tested ERPNext on QNAP NAS and I also had an issue with network. I don’t know if it is the same issue, but I have repaired it editing /etc/network/interfaces, there was incorrect logical name. Then everything worked OK.

Hi martin42,

thanks for the suggestion, i tried to add the adapter without success, but maybe this is a good way.
i will try to rename the ens3.

I didn’t have any other problem with it, I only imported the appliance, modified the configuration of the network and everything worked OK. But it was pretty slow (2cpu/4g set to vm, but host cpu was only some Celeron), in Virtualbox in my notebook it was faster. So I had to install it to classic ubuntu server anyway.

You saved me from getting ripped with erpnext :sweat_smile:

my steps to get it worked:
$ sudo nano /etc/default/grub
Change the line
GRUB_CMDLINE_LINUX=“net.ifnames=0 biosdevname=0”
Save file
Then generate new grub file:
$ sudo grub-mkconfig -o /boot/grub/grub.cfg
reboot system

then i changed the interfaces file to eth0 with static ip.
i struggled a little bit with the port, but with port 80 i get the desk.

just in the moment i stuck a little in first configuration
while creating the company and taxes (45%-50%) it stops “could not start up. error in setup”
Message: timeout

maybe it works after some retry (online search)

i will give a feedback when it works

@andrenalin Great to hear that you are making progress within Synology VMM.

What @martin42 mentioned above is really valid. Running a VM within the limited CPU/RAM of most NAS devices will have a large negative impact on overall NAS performance. Installing ERPNext on something like a headless Intel NUC maybe faster/better solution? Just attach it to your router/switch. They run cool, Use virtually no power and take up no space. If money doesn’t allow for new NUC then an old redundant office laptop with a SSD upgrade is a fast enough to deliver reasonable performance.

1 Like

Hey system19, thats a good reason to change to a stand alone system.

I would like to test first and migrate the data into a new system, if possible.

After i set the timeout to 600 to prevent the timeout error in installation i get a setup Error.

In web.error.log i have CRITICAL Worker Timeout → Everytime
I rebooted, i try 10 times the setup, clean the cache - without success

Any ideas?

I also have encountered problems with timeouts, when running in VM on NAS, solved it by increasing timeout settings. It was sometimes unpredictable, I sometimes got a timeout during normal work, problems were also with imports. Anyway, I guess it has nothing to do with ERPNext and it is performance related. On new hardware is everything OK.
When does that error appear? Already during setup phase?

Btw, if you want to play with it and set it up for production (what is actually also my situation), I recommend to use virtualization like KVM. I’m now running on CentOS7/KVM/Ubuntu16/ERPNExt, host machine is some kind of “better PC” with enough RAM and everything runs very smooth. You can test, do backups/restore, going back and forth…

the problem comes up by or after setting up company and taxes (50%).

My Nas has an atom quadcore 2,4 with 16gb ram. (rs818+ synology)
The virtual machine has 4vcpu and 4gb, i think this should be enough for a
normal installation and testing.
i can also give 6gb, my nas is only for saving data and some small web applications.

i just started the bench reinstall and will give it another try.

If this does not work i will try it with oracle on my gaming computer, there should be enough

but… there need to be a way to get it started…


after a lot of struggling i started over with a new vmm.

just now, after i make the whole configuration at first, i think i set the timeout wrong. the first post i found was only setting the http_timeout.
But you also need to setup the supervisor and nginx server :roll_eyes:

now the setup works like a charm. i have 4 vcpus and 6gb ram and can test the whole system on my nas.

thanks a lot for your support!!!

1 Like

Cool :grinning:
4 CPU and 6GB Ram is actually overkill for a test ERPNext instance. 2 CPU and 4GB Ram should be heaps. What would be really cool is a version of ERPNext that is installable from the Synology Add On Store. Open ERP has a version here. I briefly looked into what was required to create one about a year ago and it appeared complicated. I really like the smaller end of the Synology product range. They just need to add a bit more RAM by default in them to make them great. They have just released a mesh wifi router that looks excelent.

Also when happy with ERPNext, Buy a 8th Gen i5 NUC with 16GB RAM and a Samsung 970 EVO NVMe M.2 SSD… (Read 3,400 MB/s - Write 1,500 MB/s) They are fast as all heck and perfect for SMB local server.

I tested ERPNext with NUC NUC8i3BEH, 8GB RAM and Samsung 970 EVO SSD and I can confirm that even this configuration is completely OK to run ERPNext, it worked smoothly without any problems.

i thought the problems came from the lower power, but after i set the timeout correct it works really good.
i just reduce the power to 2 cpu and 2GB Ram and the first tests are really good.

i bought the rs818+ with 2gb ram, i don´t thought about more, but as i started the first vmm with 512mb :rofl:
i think about an upgrade :sweat_smile:
just in the moment 16GB are not expensive and the next step on monday is a 240gb m2 ssd cache.

maybe the system runs like a charm and i don´t need another device in the rack.

erpnext is a really powerfull software and i hope it fits completely to my needs.