Sales Analytics report "hangs" on ERPNext v7

I just updated, and was able to view the Sales Analytics report, however today in the morning when I wanted to review Sales Data, the report begins loading, the structure shows, but no graphs or data are loading. What could be happening?

Other reports such as Balance sheet, etc. load perfectly.


Working fine on my system. Can you check if there is any error on browser console? Also try some other filters on the report.

1 Like


Cannot even access the commands for the report, they are blanked out, as oyu can see in this image:

And there IS an error in the browser console…
IP Address intentionally blanked out for security.

Looks lime it is complaining about to date. Any customizations or changes you made? Try clearing cache and updating once again.

No, no customizations. It was working fine after I updated from v6, and then two days later, this happened.I have tried reloading the cache, reloading the page, changing browser windows, etc. etc. Also tried updating bench. No change.
To Date in the filter you mean right?

Any way to “hardwire” this from the background? I’m open to suggestions. Or should I just rebase again from git on this particular directory? (This is my production server but I am willing to make a copy of it and try fiddling with it.)

I have identified the directory:

And the files…

Thanks for the help, very much appreciate it!

2016-11-1 of undefined from js console.
Looks like you have some merge conflict in js file.

@Tropicalrambler, I get the same error when viewing Sales Analytics. Did you find a fix for the issue?

None yet, but I have requested a paid revision, and part of the conditions of the job will be to save up details of why the fix was needed and how it was fixed, so I can repost here!

1 Like

Fixed. See here: Sales analytics error after upgrade #7662

Waiting for the merge into master.