Sales Orders stay "overdue" without delivery note <= can that be changed?

A Sales Order will always show status “overdue” when no Delivery Note was submitted, even after the Sales Invoice was paid. While that makes sense with goods it is not quite so necessary with services.

Is there a way to unlink the Delivery Note from the workflow, so Sales Orders change to closed after the payment is received?


digging deeper, I found this in Selling Settings:

I would guess that “No” means “don’t worry about a Delivery Note being made or not” and also “don’t rely on it” for the Sales Order’s status.

Did I miss something?

It seems to be dependent on a per customer setting (yet to be confirmed)

Those settings are only a validation for the creation of sales order. (Whether a delivery note is required for a SO to be created or not.)

For your use case, you could try to check the update stock in the invoice and see if that solves it. (No time right now to check it out myself, but that should work.)

will try that, thanks Void_Moon!

@kombi you can create a list client script to override the overdue status

sounds good! Along what lines would that go?

cur_frm.states // maybe?

@kombi try this solutions : open customize form for sales order , there is a field called skip_delivery_note under company , remove the hidden and set it to default 1 .

1 Like

brilliant! Should have looked for that with F12…:slight_smile:

In Simplest form @kombi

Your sales order is asking if you have actually delivered the items or not. and that will only happen if your items have been moved out of your stock.

if you do not want to make a delivery note, Check ‘Update Stock’ in your sales invoice.

PS:- If it is a service item then it won’t say overdue :grinning: