Scheduler set to OFF automatically after update

Everything was fine until recent update from v15.1 to v 15.7 (both erpnext and frappe).

Now erpnext is not sending emails.

I checked if scheduler is enabled by running

bench doctor

and found that scheduler was set to off. I didn’t do it manually. It means during update, scheduler was set to off.

I then ran command

bench enable-scheduler

and also

bench --site enable-scheduler

Both of them returned:

Enabled for

But checking

bench doctor

again returned:

-----Checking scheduler status-----
Scheduler paused for frappe.conf.pause_scheduler is SET
Scheduler inactive for
Workers online: 3 Jobs-----

To solve this I had to manually set this to zero in common_site_config.json

“pause_scheduler”: 0,

My question here is:

  1. Why was pause_scheduler set to 1 after the recent update ? Does this mean there was something wrong with the update ?