Screen Freezes when trying to create/save MR entry

Hi Guys,

I would like to ask for your help.

Our ERPNext Web GUI freezes when trying to Create/Save new Material Request entry.

What might be causing the issue? Please help.

V12 - Ubuntu 18.04 LTS -


Edmund Valen Jr


Hi Everyone,

Can someone help me on this? or at least point me in the right direction on how to troubleshoot?

I am a beginner in Ubuntu, Py and ERPnext.

Any help is highly appreciated.


Maybe you can send logs files and browser console log

Hi Sir,

Thank you for the reply.

Can i know what system logs and browser console logs i need to send?


For browser console, open erpnext (desk) and type Ctrl+Shift+i then go to material request.

For system logs, assuming your are on production mode, go to /logs/frappe.log
If your are on dev mode, just get the info from your server console

Hi Sir,

Logs from /frappe-bench/logs/frappe.long below:

[DEBUG] 2021-07-01 13:00:09,361 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost
[DEBUG] 2021-07-01 13:01:09,460 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost
[DEBUG] 2021-07-01 13:02:09,559 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost
[DEBUG] 2021-07-01 13:03:09,664 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost
[DEBUG] 2021-07-01 13:04:09,767 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost
[DEBUG] 2021-07-01 13:05:09,868 | /home/erpnext1804/frappe-bench/apps/frappe/frappe/utils/
Site: localhost
Queued events for site localhost

Logs from Web GUI (Desk):

[HTTP/1.1 504 Gateway Time-out 120003ms]

Uncaught TypeError: e is null
always save.js:215
call request.js:260
jQuery 6
call request.js:219
call request.js:91
u save.js:203
save save.js:24
validate_and_save form.js:579
promise callbackRollup</frappe.run_serially/< dom.js:261
run_serially dom.js:259
validate_and_save form.js:570
save form.js:518
save form.js:515
Save toolbar.js:432
set_action page.js:171
jQuery 8
set_action page.js:170
set_primary_action page.js:187
set_page_actions toolbar.js:452
set_primary_action toolbar.js:367
add_update_button_on_dirty toolbar.js:467
jQuery 7
dirty form.js:936
watch_model_updates form.js:216
a model.js:423
each jQuery
a model.js:421
trigger model.js:442
promise callback
Rollup</frappe.run_serially/< dom.js:261
run_serially dom.js:259
trigger model.js:446
set_value model.js:389
promise callback*Rollup</frappe.run_serially/< dom.js:261

I hope you can help me troubleshoot the error.

is this also happened in other doctype ?

for the other doctypes i tried, non so far.

Also, i would like to note that when i open an existing Material Request, i can edit and add information. then it saves accordingly.

how ever, when i try to make a ‘new’ Material request, it is not saving and just freezes. then nothing happens.

Sorry Sir, I have no idea. Looks like the time-out error is the culprit. But it should happened to all doctype

Hi Guys, i really need your help here.

Here is the scenario that i have tried.

  • Installed a Fresh ERPNext Prod Server.
  • Configured the company on web by logging Admin account
  • tried MR entry from the newly installed ERPNext and it works fine. it submits fast.

– did the back up and restore from our live ERPNext
– MR now experiences the same issue, it is no longer saving the new MR entry and just freezes.

Please help.

also, is it possible to restore the Database only (doctype, workflow, etc not included)? and how to do it? i want to isolate the cause of the error.

Screenshot please?

hi @mohsininspire,

Please see screenshot. if this is not what you are asking for, kindly let me know so i can provide it to you.

basically, i cannot save a new Material Request, tho i can edit an existing Material Request. i am lost as to what causes the error and how to fix it. Please help. it is highly appreciated.

Other symptoms

  • The other MRs of other companies far below the 600 Entries can still work.
  • PO still works because they are below 600 Entries but slowing down
  • Its specific to the SAVE process - editing old or canceled PRs still work.
  • We have performed the MariaDB optimizations and finetuning
  • in the VM (we were able to replicate the problem in the VM by forced restore backup) we notice the HTOP ram is Under utilized - only 1.5GB Ram out of 3.8GB Ram is used.

Hi @Edmund,

I am facing the same issue. In my case workflow is the culprit. If I deactivate the workflow then it saves in normal time but with workflow active, it takes 2-4 minutes time to save. My MR workflow consists with 7 states and 45 transition with conditional statements.

I am suing the same v12.

Hope it would help you.

hi @pioneerpathan,

so far, it seems that workflow is the culprit, i deactivated the workflow set for MR and it was saving properly.

Thank you very much on pointing me to the right direction. this is very much appreciated!

our deployment is far from perfect, but at least after fixing this we can use our system again! and i am working on figuring this out.

again, thank you very much sir! cheers!


i am encountering issues when my workflow are assigned to specific roles (ie Manufacturing User). but when i set the workflow roles into ‘all’ it saves quickly.

what could be causing this behavior?

1 Like

Created an Issue Report in the Github. First time doing this so not sure if I did it correctly.

Hi Everyone,

Just to update you and for others who experience the same issue as ours.

The problem lies on the users and workflow.

the fix is to re create a new user (example MR user) and give same access to doctypes as the erroneous user and assign it to the workflow.

Thanks for everyone who help give insights to help us fix the issue.


Hi @Edmund

In our setup we’re experiencing this also, could you elaborate to your solution?


Hi Jerimiah,

Do you still encounter this issue?

Maybe I can help