Screen Greys out Permanently on Certain Screens

Got a truly strange problem. Certain screens grey out permanently when accessed e.g. Sales Invoice List, Purchase Invoice List, Supplier Quotation List, and Journal Entry List. Some screens are fine e.g. Customer, Supplier, Item…

This is a new dev system without any modifications. There were documents created but we have since deleted all company transactions.

Please see image below:

Any ideas?

please try to run update , and clearing the cache…
anyway please see the web console

Updated already, cleared cache already, web console is blank.

then please check the server error log

Yes i have, i cant seem to spot anything odd at the moment. Any other ideas?

What I can’t seem to understand is why it only affect certain screens?

Same here after the last update!

I get the same or a very similar result. But mine only seems to happen on the POS. But then it persists afterwards.

I’ve had this happen a couple times. No indication why here either.

Can you please share the JS error logs?

Also getting this. Developer mode in chrome shows this:

form.min.js:210 Uncaught TypeError: Cannot read property 'Time Log' of undefined

This was when I attempted to enter a submitted Time Log. Entering a document will throw the name of the particular doctype.

@rmehta same here

@rmehta I think there is the problem of the commit of @anand that cause this problem

@ccfiel thanks! let me have a look.

1 Like


@rmehta still the same problem :frowning:

@ccfiel how do I replicate it?


Use Case:

  1. Go To User List
  2. Click and Existing User.
  3. Form will not display. Only blank space.

and when you inspect from console this is the error

form.min.js:2088 Uncaught TypeError: Cannot read property 'Core' of undefined

Cannot replicate. Have you pulled latest?

For me, i dot get the same JS error as @ccfiel when i browse User Listing and Click Existing User.

However for Sales Invoice its just a blank screen without and JS errors even in developer mode. I’ve pulled latest BTW.

@rmehta yes I have. when I do a git show

commit 4347fac6a1f168a678e7657b5ad8520a0b599a42
Author: Rushabh Mehta <>
Date:   Wed Jun 8 11:43:12 2016 +0530

    [fix] document_flow.js

diff --git a/frappe/public/js/frappe/form/document_flow.js b/frappe/public/js/frappe/form/document_flow.js
index 70cac7b..99cca98 100644
--- a/frappe/public/js/frappe/form/document_flow.js
+++ b/frappe/public/js/frappe/form/document_flow.js

This is weird :frowning: why you are not getting the same error.