Server Error: Please check your server logs or contact tech support after update erpnext and Frappe from v8.x.x to ERPNext: v12.x.x

Traceback (most recent call last):
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 55, in application
response = frappe.handler.handle()
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 20, in handle
data = execute_cmd(cmd)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 55, in execute_cmd
return, **frappe.form_dict)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 1007, in call
return fn(*args, **newargs)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/desk/”, line 17, in get_user_progress_slides
slides += frappe.get_attr(fn)()
File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/utilities/”, line 282, in get_user_progress_slides
s.done = get_action_completed_state(s.action_name) or 0
File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/setup/doctype/setup_progress/”, line 20, in get_action_completed_state
if d.action_name == action_name][0]
IndexError: list index out of range

Hi @Phuc_Tran,

your error is an index out of range exception:

IndexError: list index out of range

and this was reported in

if d.action_name == action_name][0]

This line is definitely broken (check ]). Have you modified File “/home/ubuntu/frappe-bench/apps/erpnext/erpnext/setup/doctype/setup_progress/”? Or on which branch are you (develop)? The sources seem to be fine…

You can try

$ bench update --reset



I just updated the latest source as your guide. But i am still receiveing the same error message when i login to system.


Can you please check your source code in /home/ubuntu/frappe-bench/apps/erpnext?

What is the result of

$ git status

Maybe checkout a valid source branch, e.g.

$ git checkout master

Then perform with a bench update from the frappe-bench folder

1 Like


When i switchto master and fixed it. But i can’t deploy it again.

Try bench migrate and then bench start again


It is working back now. But it is still having error message as before.

Please help to check.
I am using verions:
Installed Apps
ERPNext: v10.1.57 (master)

Frappe Framework: v10.1.50 (master)


I don’t know why i can’t login to system now. i am receiving this error. Please help to advise
jquery.min.js:4 POST 500 (INTERNAL SERVER ERROR)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
call @ frappe-web.min.js:875 @ (index):506
(anonymous) @ (index):416
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3
frappe-web.min.js:960 Traceback (most recent call last):
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 59, in application
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 121, in init_request
frappe.local.http_request = frappe.auth.HTTPRequest()
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 53, in init
frappe.local.login_manager = LoginManager()
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 107, in init
if self.login()==False: return
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 126, in login
self.authenticate(user=user, pwd=pwd)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 206, in authenticate
self.user = self.check_password(user, pwd)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 222, in check_password
return check_password(user, pwd)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/utils/”, line 35, in check_password
)“”“,{ ‘doctype’: doctype, ‘name’: user, ‘fieldname’: fieldname, ‘pwd’: pwd }, as_dict=True)
File “/home/ubuntu/frappe-bench/apps/frappe/frappe/”, line 166, in sql
self._cursor.execute(query, values)
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 170, in execute
result = self._query(query)
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 328, in _query
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 516, in query
self._affected_rows = self._read_query_result(unbuffered=unbuffered)
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 727, in _read_query_result
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 1066, in read
first_packet = self.connection._read_packet()
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 683, in _read_packet
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 220, in check_error
File “/home/ubuntu/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/”, line 109, in raise_mysql_exception
raise errorclass(errno, errval)
InternalError: (1054, u"Unknown column ‘salt’ in ‘field list’”)

process_response @ frappe-web.min.js:960
(anonymous) @ frappe-web.min.js:905
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
z @ jquery.min.js:4
(anonymous) @ jquery.min.js:4
load (async)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
call @ frappe-web.min.js:875 @ (index):506
(anonymous) @ (index):416
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3

Raise an issue on Github. Or if you cannot wait then you can correct it yourself. Just delete the extra closing bracket after action_name. The file name has been indicated just above that line.

For this second one:

Run bench update --patch and then start

System is wokring back but it has error message when i logged into system.

and i can’t reset password for other users.


Hi, Did you solve it?
Thanks for advance