Set Precision at 0(zero) for amount collumn

I set global number at #,###.## but for " Amount" collumn , I need Precision as 0(zero),please assist to add code for this case .
Below is image showing where I want to add 0(zero)

Someone can help me for this issue

Pleasse assist to review for this case .

Please give an example where we can understand what is the end result you wish to achieve ?

Hi @root13F ,please see my image , just want to round off the Amount .rounding%20off

Have you experimented by setting currency precision to 2 or 1 as per your needs in System Settings.

Try setting it (I don’t recommend it on your production server but only local instance), and create some documents and see if you like what you get.

Hi ,
I try as your suggest ( set Curency Precision as 1 ) but till have one digit Precision . what I need is no digit after “,” .

Do you mean just whole numbers not even a zero after decimal point ?

Yes @root13F , what I need is “13.789.091” in Amount collumn.

That comes to locale settings i guess. You are talking about conventional used in EU i guess ?

Hi @joshiparthin , No , I live in Vietnam .

One possible solution is to set that field’s Type as Int or Integer.

Do you want this just in one report or do you wish these changes to be enforced over the entire system ?

Also, why are the commas and decimal points exchanged in your figures. Check if in System Settings, under section DATE AND NUMBER FORMAT, the field number format has this


or not. I think the separators have been interchanged by mistake or is it a requirement.

Hi @root13F ,
1.Please advise how to change to Integer as when I change from Currency to Int , there is error " Fieldtype cannot be changed from Currency to Int in row 31" .

2.I need this in all form like Quotation, Sales Order,Purchase , Invoice ,…

3.For commas and decimal points , we apply " #.###,##" as it’s common in Vietnam ,that’s all so It is a requirement .

Hi @root13F, can you review ?