Setting custom field bug for dropship?

Hello, I set a custom Data field in my sales order and purchase order Docs
Label: company_abbr
Type: Data
Name: company_abbr
Option: company.abbr

When I create a new PO or SO this easily retrieves the company abbreviation and puts it into the company_abbr field. The strange thing is that when I make a purchase order from a sales order(drop ship), company_abbr is blank, the field doesn’t retrieve the value. Is this a bug or am I doing something wrong?

Can you provide screen shots?

Is field name for Company Abbreviation same in Purchase Order as Sales Order? Have you written any custom script in Purchase Order to have abbreviation fetched? A usecase for having abbreviation fetched in the transactions, even when Company Name is fetched?

@Pawan @umair

okay. So, I’ve done some experimentations. Looks like if company_abbr is the same in both the SO and PO, the PO’s company_abbr will be filled. But I’m not sure it’s a fetch from “company.abbr”. But maybe a “copy over” from dropship SO when I created the PO.

When I create a PO from dropship SO, I would like to do a fetch on load. I tried a DIFFERENT variable:
Purchase Order’s Form:

Here’s the screenshot of the PO created from the dropship’s SO, country.abbr was probably copied over and was not fetched (THIS IS WHAT I’M TRYING TO ACHIEVE):

  • I tried with AND without a custom script, its a one-line script in PO: cur_frm.add_fetch(“company”, “country”, “country”);
    I’ve attached a screenshot of that too. Again, I tried with and without

If I select the company after page has loaded than Country is fetched. But I would like to do this on load. Is this a bug that it doesn’t?