Setting the default for a checkbox as 1 in the Sales Invoice DocType is not rendering it checked

We have manually added a custom checkbox for the Sales Invoice and set its Default value to 1. Yet, when it is rendered, the checkbox is unchecked.

Can you click on update again and refresh the page? If the issue persists, send screenshots of the custom field (expand the row in customise form) so that we can debug this.


It does not work for existing invoices but, when drafting a new invoice, it works as expected.

Note: Tried to Ctrl + Shift + R the page on Microsoft Edge (Chromium) on a draft invoice, it did not work.

Should still be classified as a bug, right? :thinking:

  • DocType
    It has been customised to include a custom Show VR field

  • Unexpected
    This invoice is a draft; and as seen, the Show VR field is unchecked

The customisation will not be applicable for already created documents (either in draft or submitted state). It will be only applicable for new documents.

Hope this helps!