Setting up lets encrypt and ssl (unable to resolve host)

Hi everyone.
I am currently running production on a VPS.
I have my Domain and its pointed to my VPS IP.
I am trying to use lets encrypt.
when i run
sudo -H bench setup lets-encrypt site1.local --custom-domain MYDOMAIN
the result is
unable to resolve host MYHOSTNAME: Name or service not known

Did it through certbot directly it seems fine.

do you have nginx setup?

This command has not really been very useful since the conversion of Frappe/ERPNext to Python 3. The old command relies heavily on python 2.7 and is only going to work on v11 and older installs that still use python 2.7


Yep I have Ngix installed.
As said i installed certbot, recognized the site and installed ssl no problemo.

Tnx, I actually follow you and use your stuff alot.
You’re easy install on ubuntu 20.04 was a bless.
You and some other members are a true blessing, tnx for helping the noobs.

For other people getting into the same problem.

So it looks like if you are running python 3 (which u probably are):

just go here and follow the steps.
worked for me.