Setup unicode issue

Hi all:
First… I love ERPNext.

I’ve installed early 2015 in Ubuntu 12.10. I started working on it and allways go perfect.
I’ve tried to update translations (to spanish) and the system crash. Don’t matter, It’s not the point of this topic.

The issue is that when I try to install again(fresh install, ubuntu server from zero), I follow the easy installation instructions (from Github). It’s ok.
When I try to setup ERPNEXT from browser, I Select Spanish language, and fill the options, At last Step ERPNext show this error message:

Traceback (innermost last):
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 51, in application
response = frappe.handler.handle()
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 66, in handle
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 89, in execute_cmd
ret =, **frappe.form_dict)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 532, in call
return fn(*args, **newargs)
File “/home/erpnext/frappe-bench/apps/erpnext/erpnext/setup/page/setup_wizard/”, line 34, in setup_account
File “/home/erpnext/frappe-bench/apps/erpnext/erpnext/setup/page/setup_wizard/”, line 203, in install
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 162, in insert
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 449, in run_post_save_methods
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 412, in run_method
return Document.hook(fn)(self, *args, **kwargs)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 496, in composer
return composed(self, method, *args, **kwargs)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 479, in runner
add_to_return_value(self, fn(self, *args, **kwargs))
File “/home/erpnext/frappe-bench/apps/frappe/frappe/model/”, line 406, in
fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
File “/home/erpnext/frappe-bench/apps/erpnext/erpnext/setup/doctype/item_group/”, line 24, in on_update
File “/home/erpnext/frappe-bench/apps/frappe/frappe/website/”, line 38, in on_update
File “/home/erpnext/frappe-bench/apps/frappe/frappe/website/”, line 170, in clear_cache
File “/home/erpnext/frappe-bench/apps/frappe/frappe/website/”, line 11, in delete_page_cache
cache.delete_value(“page:” + path)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/”, line 31, in delete_value
File “/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/”, line 477, in delete
return self._deletetouch([‘DELETED’, ‘NOT_FOUND’], “delete”, key, time)
File “/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/”, line 495, in _deletetouch
server, key = self._get_server(key)
File “/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/”, line 385, in _get_server
serverhash = serverHashFunction(key)
File “/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/”, line 65, in cmemcache_hash
(((binascii.crc32(key.encode(‘ascii’)) & 0xffffffff)
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc3 in position 39: ordinal not in range(128)

Run this from frappe-bench folder:
./env/bin/pip --upgrade python-memcached==1.53


Hi anand,
I have the same problem with Khmer script. I tried to run: ./env/bin/pip --upgrade python-memcached==1.53
from frappe-bench folder and here is what I had :

pip [options]

no such option: --upgrade

I don’t really know what to do.

Thx in advance for your help guys!

Are you on version 4?

You are missing install in pip. Try: ./env/bin/pip install --upgrade python-memcached==1.53.

It’s working thx!!!

I receive requirements regarding item or database level translations using Unicode. Is erpnext supporting Unicode translations and if yes then is it possible at database level rather than just the translations of frontend.