Setup Wizard Freezes in step 4 - Frappe 8.0.7/ ERPNext 8.0.8 on Ubuntu EC2

  1. Installation successfully completed using easy install steps.
  2. Each time the setup wizard freezes at step 4 ‘Select you domain’ after selcting one option hitting Next and nothing happens.

already tried bench update and other suggestions on posts here that reported wizard freeze issues.

is there any exception on browser console ?

I have attached screenshots of error console logs from safari and chrome browsers.

issue seems to be in the same javascript…libs.min.js

on chrome -

libs.min.js : 7691

Uncaught SyntaxError: Invalid regular expression: /(^|>|\s|.|-|/|\|,|$|!|?|:|;)(aa)($|<|\s|.|-|/|\|,|$|!|?|:|;)/: Stack overflow
at RegExp.exec ()
at RegExp.[Symbol.match] ()
at String.match (native)
at m.formatDate (
at (native)
at m._setInputValue (
at m.selectDate (
at Class.set_input (
at Class.prototype.(anonymous function) [as set_input] (

Any clue how this needs to be resolved. Can I try installing a more stable version… if so can you provide the script or git link to script for this please.


I have been waiting on a response to this - i am surprised no one else faced this. I even went on to use a completely new ubuntu server and did a full install - once again the same issue - step 4 of wizard freezes. :frowning: :rage:

I think the issue is related to different timezones.
Just pushed a fix. Date recursion fix in General Ledger by netchampfaris · Pull Request #3058 · frappe/frappe · GitHub

Can you please test it, before we merge it into the repo?

I have this problem too. :frowning:

netchampfaris - the solution worked for me.
rafaelp - pl use the provided GitHub pull