Site Cant be reached

Hi! i have installed and followed the frappe library management tutorial. however when i try to open the http://library.test:8000 site it shows - This site cant be reached on my browser (attached below).
I have added the library.test to hosts in /etc/hosts
Bench is running on a remote server.
The port 8000 is also forwarded to my


Hi @Adithya_Shankar:

Check firewall. Port 8000 is open in remote server?
It works using IP address instead sitename?

Hey! thank you very much for your quick response. I have checked my firewall. port 8000 is open.
By IP you mean the IP of the server? I have tried Public IP of the server. → Did not work
I have tried the → Did not work. But when I hit this uri, i get a 404 log in my bench start terminal

I get this last line (404) when i hit on on my local

Please let me know if you need any other details, or anything else. Any help would be appreciated very much.

Hi @Adithya_Shankar:

I’m confused with this :slight_smile:

Are you trying from your Mac browser … server is VM running locally?

Sorry for the confusion… Yes! I am running my frappe-bench on a VM (GCP). I am forwarding the port (8000) on which bench is starting. and i am opening the library.test:8000 and on my mac browser. and both result in same.

Ok, try on your console:

bench use library.test
bench start
1 Like

Thank you very much!! It works now - when i open with
But when i try with library.test:8000 it does not open. Not sure why though. Is it because library.test is mapped in my remote server to but not in my mac?

1 Like


Try ping library.test from your Mac terminal.
Is it reaching your remote server?

it throws unknown host

So … where have you modified hosts file? On MAC or remote server?
Do it on MAC side … pointing library.test to your server public ip address.

on remote

Ok, do it on MAC side … pointing library.test to your server public ip address. :slight_smile:

1 Like

works… thank you

I am trying the same thing, but the message “website not found” keeps coming up.

Hey… Have you tried the above suggestions?? Those have worked for me