Site has started to slow down on Chrome [V8]

Here a strange thing,

On Chrome the site takes a lot of time to load, while in Safari it is very fast.
Recently we have been added a lot of Items in the site. Around 6000 Items in total. And some other transactions. But Items is the one that we have been working the most.

On digitalOcean I see the monitoring and it does not show server overload or anything.

This is the console of Chrome:

And Safari console:

Any suggestion on this? Has anyone encountered this issue?

Should the team still be supporting [v8] given the lack of resources they have?

1 Like

Any suggestion on this? Has anyone encountered this issue?

I have. But this is on v7. Only solution was to switch to a different browser.

A client uses v7 and we have the same issue with chrome AND chromium + weird bugs like:

  • Not all the options of a dropdown are displayed
  • The date widget displays a series of 1’s, 2’s and 3’s instead of the dates of the month.

The problem’s don’t appear in Firefox and Avast Secure browser.
Might be a browser thing, but could also be a problem with old libraries running on new browsers.

Haven’t encountered the problem in v9 and v10.

I will try to update. I hope I don’t have any issues with custom code.

@littlehera @adityaduggal Tried with version 10 and still the same issue. The site barely opens on Google Chrome while on Safari it opens immediately. And I do not know where to start to diagnose the issue.

I have the same problem on v10 using both Firefox and Chrome. It’s so bad that when I clicked wait instead of cancel, the computer completely frose and had to be forced off to restart.

I have tried changing to a bigger server (8GB). This doesnt help a little bit. It seems to be a client-side (overload???) problem.

Any common browser addons/plugins between the FF/Chrome vs Safari?

Adblock Plus and uGet.

Let me disable these and retest.

Interestingly, Disabling Adblock Plus seems to have improved things. I’m not entirely sure that the problem is solved, I’ve re-enabled the plugins and things seem to be working fine still (with the same plugins). I’ll continue testing.

Thank you so much for the timely hint. I was just about to go through the trouble of upgrading my site to v11 and custom plugins :sweat_smile:. Phew! Saved me a lot of trouble!

@aldoblack, and @littlehera did you have any of these plugins? Did anything help in your cases?

Kindly share here until we get this issue under control :slight_smile:

I have found that using the MVPS hosts file minimizes the “stress” on Adblock. I also switched to uBlock origin as it seems to be lighter/faster