Site shows Welcome to Nginx

Right so, I set up DNS multitenancy like the frappe guides, I added a custom domain to my site, works all fine, then I added ssl using the lets encrypt method, it didnt work said certbot wasnt working and all. That somehow screwed up my nginx. When I run sudo service nginx reload it saysnginx not running, if i run sudo service nginx start it says job failed with exit code. When i run system status this is what I get:

Any help guys?

Okay so I completely removed nginx and reinstalled it, turned dns multitenancy on, added a custom domain, ran bench setup nginx, ran sudo service nginx reload, everything is fine except whenever I access my site it shows the Nginx Welcome Page. Any help?

What does bench setup nginx report?

Um nothing? It runs perfectly fine, so does sudo service nginx reload. It asks for confirmation to overwrite nginx.conf nothing else

sudo systemctl status nginx reports how many tasks?

Also there’s this funny behavior of sorts by the site. If i access the site in a new tab it shows me the nginx page, if i reload it, it says site cant be reached as in if the site is down or something

What does:

sudo netstat -nlp | grep nginx report?

see what the /var/log/nginx and letsencrypt logs have to say, post anything relevant - maybe someone can decipher things. It appears that the bench setup nginx is not picking up your sites.

how do i access the logs?

The tail command will be useful.

Right, so I accessed the logs for both and nothing. No aberrations, no unusual things at all. My nginx.conf has the sites mapped perfectly for their domains