error 404 response

Do you all know what cause of this error ? or how can i inspect the error ? Your help is greatly appreciated. I am using v8.0.1 beta.

Can you try to re-install,
npm install redis express superagent cookie

@Pawan yes, i tried this before, it will always async with non stop every mini-second, something like the photo below:

is this normal ? In addition, it made my erpnext unable to function well since the processing taken by the frappe.async.get_user_info… i do not know what is the problem.

Unable to function well meaning, it stuck on the web page.

Can you run, bench update?

@Pawan is the bench update will affect the code that i made changes on ?

If you have made changes to core files, it will not update successfully.

@Pawan , i thinking to back up the bench-repo and frappe-bench folder, in case i am not successfully update, then i can replace the backed up folder into same location, and it will function as previous, am i right ?

@jcyh Are you on Frappe v7? Because it is not compatible with the latest

If the above is true for you, run this :

npm install

this will install at 1.7.4 which is the last version that supports v7 frappe.

I am using v8.0.1beta develop environment, master branch

@vjFaLk, i tried the solution you mentioned, unfortunately it still hit the same error.

I realise it hit the error when i access using the erpnext mobile app, when i use back browser, the doesn’t hit 404 error…

But i still couldn’t what is the problem.

run bench restart after running that npm command

Same issue.

You manually (not via bench command) set up nginx.conf or for some reason don’t have tho node package installed might be a reason for such error.
In this case you have to check if you have installed and listening as server then configure it in nginx.conf or the appropriate included configuration file.

How to find on which port is running server?

can see how the server is started in frappe-bench/apps/frappe/socketio.js

search for it’s configuration variable value:
grep -R socketio_port ./frappe-bench/

check where node process is LISTENING (Ubuntu command) lsof -i| grep LIST

1 Like

any luck on this issue