[Solved] After update erpnext to 10 Dynamic Link broken

Hi everyone,
after bench update and change to version 10 i have problems with dynamic links, i can’t read this doctype and return me a permission error.
I try to modify some role but can’t view dynamic link in the list.
Thank for the attention


I use API to read dynamic link check the relation with the address and customer, other doctype works.
I have a user with all permission, before the update all works fine.

1 Like

Please edit your post and post some screenshots of the steps where you are facing problem.

I had a screenshot with the api call, i can’t understand if there were some change between version or if the update made an error somewhere.

Anyone can help me?

Try bench migrate and try opening it again.

I tried, but the problem persists; I recovered a backup of the machine and confirmed that before it worked, I checked if there were differences in the doctype or permissions, but nothing.

I wrote some scripts use dynamic links, after this update they no longer work.

Otherwise how can I get the name of an address or a contact starting from the customer’s name

I tried to install a new machine from scratch and dynamic links via API can not be used anymore. It blocks me saying that I do not have permissions and makes my script unusable.
It’s a new addition, can you get around or is there a reason behind this choice?

Probably something escapes me, some advice?

The problem was related to the change made on frappe with regard to the children’s access tables via API

In the GET request, add the parent parameter, which will be used to check permissions
ex. http://your-site.ext/api/resource/Dynamic Link?fields=“*”&parent=Address