[solved]Bench update error 26th Dez 2015

Hi all,

just tried to update via bench update… following was thrown

frappe@erp:~$ bench update
Already up-to-date.
Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages
Von https://github.com/frappe/frappe
 * branch            master     -> FETCH_HEAD
Aktualisiere 0012ccc..abd4cc7
error: Your local changes to the following files would be overwritten by merge:
Please, commit your changes or stash them before you can merge.
Traceback (most recent call last):
File "/usr/local/bin/bench", line 9, in <module>
load_entry_point('bench==0.92', 'console_scripts', 'bench')()
File "/home/frappe/bench-repo/bench/cli.py", line 60, in cli
File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 716, in __call__
return self.main(*args, **kwargs)
 File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 696, in main
rv = self.invoke(ctx)
 File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 534, in invoke
return callback(*args, **kwargs)
File "/home/frappe/bench-repo/bench/cli.py", line 241, in _update
update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
File "/home/frappe/bench-repo/bench/cli.py", line 256, in update
File "/home/frappe/bench-repo/bench/app.py", line 90, in pull_all_apps
exec_cmd("git pull {rebase} upstream {branch}".format(rebase=rebase, branch=get_current_branch(app, bench=bench)), cwd=app_dir)
File "/home/frappe/bench-repo/bench/utils.py", line 105, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull  upstream master

I even grabbed pdf.py from the master branch and pasted into the installation then restarted the server but still the same error

any ideas??

just reinstalled the frappe folder… now back to normal

You had local changes.

Hi @rmehta

thanks, yeah I accidently hit the wrong machine with the file during testing :blush:
my bad, sorry.