Solved: Install system user questions

Issue solved. I made mistakes during install. “Easy way” works.

Dear forum members,

I tried to follow this doc "Easy way:: but I have some questions:

Under “Running the bench” it says ‘For production: Configure supervisor and nginx’. Then some descriptions of services that all end in “bench start”. Hmmm…

Then I see “Production Deployment”. Ah HA! This is what I want. But it says run sudo bench setup production.

Next I see “Supervisor” & “nginx” with a bench & a ln command to run – no problem!

Then EOF. :-[

So how should I start this to run as a service? Thanks for your help!

“erpnext”: “6.22.1”,

"frappe": "6.23.3"

Sorry, I see the sudo befor the bench setup. But do I always need to use sudo? -Thanks

Also, I get this error:

sudo bench setup production
Usage: bench setup production [OPTIONS] USER

Error: Missing argument “user”.

isn’t the so called “Easy way” this
in short

sudo bash --setup-production

if you use the manual install (where you linked points at) you’d run bench start to start the service I’d say

It can be you need to cd /home/frappe or cd home/frappe/frappe-bench before running bench start (assuming you are logged in as user frappe)

@dudeman default user should be frappe

Thank you for the replies. I will test again!

$su frappe
No passwd entry for user ‘frappe’